Razer Naga issues

Mac Technical Support
Hello, I haven't played in a while but I am wondering if anyone has had the issue of their modifier keys not working in juncture with the Razer Naga mouse. If anyone has insight please post, thanks
http://pqrs.org/macosx/keyremap4macbook/As far as I know this is the only fix...

You may need to clear your macros and if you have modifiers added in them. Some people stated that this worked for them.
Mac Tech Support for Baaaaahlizzard Entertainment
Not finding what you need here? Contact a rep direct! http://us.battle.net/support/en/article/contact

To fix bugs, simply blow on the cartridge...
Hi, I've been having this problem since I updated to the new (and evidently bugged) Synapse drivers 2 months ago. I've been in contact with Razer Tech support and they don't know what's wrong. I've tried everything you can imagine, reinstallation of the drivers, rolling back to pre Synapse drivers, the Exposé fix and the Keyremap4macbook, updating firmware (on Windows, ewwww).
Nothing works, not even Keyremap4macbook, since it usually stops working in 30 mins or less; I have to kill the process and start a new one.

Any new info on this Machkhan?
BTW, I don't use any macros, and the bug is not limited to WoW, if I go to TextEdit and press shift+1 I get 11111 instead of !!!!!!

Interesting bit: I repaired disk permissions (for a different reason) and modifier keys started working again. Alas, as soon as I logged out/restarted, the issue resurfaced.
Today I had to remove Messages Beta for Mac.
After restarting, modifier keys work again... I don't know what happened and I'm afraid I'll lose them again after a restart/log out...

This would be something that Apple may need to look into if it is happening outside of WoW. I'd suggest taking your Mac to the local Apple store or contacting AppleCare for additional assistance.
Hi Machkhan!

Now I'm completely baffled. Modifier keys + Naga are only working in WoW.

I hope it continues like this. Maybe I'll try on SC2.

We don't have Apple stores in Mexico.
I don't have AppleCare (5 year old iMac).
04/05/2012 08:38 AMPosted by Fyveonit
http://pqrs.org/macosx/keyremap4macbook/As far as I know this is the only fix...

I have tried this, and it does nothing. Is there anything to it that I should not that isn't obvious?
Should know* sorry, I also check out that link you posted, Machkhan the app you suggested I download (I think) doesn't open. It just crashes instantly before I can do anything.
I didn't mention an app to download I believe. I suggested the terminal workaround but thats all I remember.
Mac Tech Support for Baaaaahlizzard Entertainment | Sun-Thur

I'm not big on boasting, but you might have to take a victory lap.
You're a saint, fixed. Thank YOU!
Received a driver update from Razer today, and my modifiers no longer work either. Running Alienware, so this can't be fixed with the Mac update. Anybody having the same issue?
got the update yesterday- had problems with the 9-12 buttons on the side. before yesterday, never had a problem.

running 3 different flavors of windows and linux mint 11.

Join the Conversation

Return to Forum