Random disconnect issues

Mac Technical Support
I have been constantly disconnecting for a good while now (since around patch 4.2 or so, everything was rock-solid before that)… randomly every few hours, any time of day or night. I got frustrated and stopped playing for a month or so since I could not reliably raid, but I would like to be able to play again since I have had virtually NO issues at all with my connection dropping in the years that I have been playing, and I was hoping that interim patches would have fixed the anomalies. I am somewhat IT savvy and comfortable around Mac troubleshooting and a unix terminal, so I have tried everything I can think of.
--There is no pattern, rhyme or reason to the disconnects and it happens very suddenly (no running in place/etc) during the disconnect, everything else on the system works fine (itunes or ventrillo etc.). It has happened in just about every circumstance… sitting idle in town, in LFR raids, in regular 10-man raids, in instances, while ghostcrawling back to my corpse, at the auction house, flying around farming, etc etc etc.

System details
Model Identifier: iMac7,1
Processor Name: Intel Core 2 Duo
Processor Speed: 2.4 GHz
Number Of Processors: 1
Total Number Of Cores: 2
L2 Cache: 4 MB
Memory: 4 GB
Bus Speed: 800 MHz
ATI Radeon HD 2600 Pro:

Chipset Model: ATI,RadeonHD2600
Type: GPU
Bus: PCIe
PCIe Lane Width: x16
VRAM (Total): 256 MB
System Software Overview:

System Version: Mac OS X 10.6.8 (10K549)


ISP - Comcast cable
Country - usa
Modem (and firmware version if known) - Sci Atlanta/Cisco DPC2100R2 v2.1 hardware / dpc2100R2-v2.0.2r1256-100817as software
Router (and firmware version if known) – linksys wrt120n
Network device (Driver version if available) - Marvell Yukon Gigabit Adapter 88E8055 Singleport Copper SA (stock iMac stuff)
Type of connection used (Wireless / USB / Ethernet) - Ethernet
Operating System - Mac OS X 10.6.8 (10K549)
Security Software installed (Firewall, Anti-Virus) – none
Traceroute to your realm –
1 ( 1.367 ms 0.161 ms 0.104 ms
2 c-71-224-254-1.hsd1.pa.comcast.net ( 41.259 ms 23.384 ms 29.741 ms
3 xe-10-1-0-0-sur01.columbusblvd.pa.panjde.comcast.net ( 8.610 ms 8.764 ms 11.926 ms
4 xe-3-1-3-0-ar03.newcastle.de.panjde.comcast.net ( 10.473 ms 12.575 ms 12.661 ms
5 pos-5-13-0-0-cr01.ashburn.va.ibone.comcast.net ( 15.659 ms 14.058 ms 15.879 ms
6 pos-0-2-0-0-pe01.ashburn.va.ibone.comcast.net ( 18.718 ms 16.695 ms 16.422 ms
7 ( 17.841 ms 15.726 ms 16.424 ms
8 cr1.wswdc.ip.att.net ( 85.627 ms 118.593 ms 85.026 ms
9 cr2.sl9mo.ip.att.net ( 81.994 ms 85.212 ms 83.048 ms
10 cr2.kc9mo.ip.att.net ( 86.658 ms 85.197 ms 83.182 ms
11 cr1.dlstx.ip.att.net ( 81.985 ms 83.040 ms 84.816 ms
12 cr1.phmaz.ip.att.net ( 110.196 ms 84.051 ms 83.856 ms
13 cr1.phmaz.ip.att.net ( 81.411 ms 83.535 ms 79.310 ms
14 12-122-254-50.attens.net ( 79.995 ms 81.199 ms 81.597 ms
15 mdf002c7613r0002-gig-10-1.phx1.attens.net ( 81.568 ms
mdf002c7613r0001-gig-12-1.phx1.attens.net ( 81.267 ms
mdf002c7613r0002-gig-10-1.phx1.attens.net ( 84.063 ms
16 * * *
etc etc


Modem stats
RPL - 9.0 dBmV
SnR - 39.1 dB
TPL - 45.9dBmV


Nothing recent in /Applications/World of Warcraft/Errors

LOGS: (several instances of this identical right after a disconnect… nothing too helpful)
4/5 08:32:53.327 ** Loading table of contents Interface\GlueXML\GlueXML.toc
4/5 08:32:53.327 ++ Loading file Interface\GlueXML\StarterEditionPopUp.xml
4/5 08:32:53.327 Error loading Interface\GlueXML\StarterEditionPopUp.lua

4/5 08:32:53.347 Client initiated Disconnect from
4/5 08:32:53.364 GRUNT: state: LOGIN_STATE_DISCONNECTED result: LOGIN_OK
4/5 08:32:53.364 Login program=WoW platform=Mac locale=enUS
4/5 08:32:53.364 Component WoW.Mac.15354
4/5 08:32:53.364 Component WoW.base.15354
4/5 08:32:53.364 Component WoW.enUS.15354
4/5 08:32:53.364 Component WoW.enUS.15354
4/5 08:32:53.364 Component Tool.Mac.2730


Other things I have tried:
reinstalled WoW
reinstalled OSX
deleted wtf and cache multiple times
tried repair tool
Flushed DNS
Renew DHCP lease
various computer and router MTU sizes from 1350 - 1500
firewall up and down on both router and OSX
static address with ports forwarded
with and without router QoS on WoW/B.net ports
tried different characters on different realms
tried windowed and full screen
tried capping FPS at 30
tried various graphic settings
tried to recreate crash running applications in the background and not
tried everything without addons
scoured the OSX console logs for any other abnormalities or errors (found none at all)
etc etc etc
Are you disconnecting from the internet or just the game?

Try adding SET timingMethod "1" to the World of Warcraft/WTF/config.wtf file.
Are you disconnecting from the internet or just the game?

Try adding SET timingMethod "1" to the World of Warcraft/WTF/config.wtf file.

Just the game is disconnecting. I had that cVar in my config file for a while and I didn't see all that much difference. I tried it last night and it seemed to reduce the number of disconnects, but I still had a few.
Just an update for anyone searching for this issue in the future... I am still having the same disconnect issues in regular WoW client, but I have been testing the Pandaria beta as well and I have been having none of the issues in that... if that is helpful at all.
Have you tried just bypassing the router all together and tried directly connecting to the modem with an Ethernet connection?

And can you confirm that your WoW Launcher states "World of Warcraft is up to date"?

One last thing, you've mentioned deleting the WTF and Caches, but what about the Interface folder, where the add-ons and other temp files live? Has this been deleted with the WTF/Cache folders and tested?
Mac Tech Support for Baaaaahlizzard Entertainment | Sun-Thur

I'm not big on boasting, but you might have to take a victory lap.

Join the Conversation

Return to Forum