Paid services down?

Customer Support
yup 3rd card no luck either...
04/09/2012 07:50 PMPosted by Sobaka
yup 3rd card no luck either...


You aren't going to have any luck, the services are still down.
Hmm.. mine doesn't show on the bank either, however if you go into Character Transfer History in Account Management, it says pending. My guess is it will go through when they're done fixing the system. My impatience has already got me stuck in pending when I should've known better and waited (lol).

Even if yours isn't showing up as pending in Account Management, it might be a good idea to hold off on trying new cards. Just in case. You don't want to get charged 3-4 times like it seems others have. Granted, they should credit you back if you call billing.. but it's always better not to have the hassle. Hopefully there will be an update in the morning.
04/09/2012 07:52 PMPosted by Scuba
yup 3rd card no luck either...


You aren't going to have any luck, the services are still down.


They seem to be back up I am able to get into it and go thru with it... it just keeps declining my payments.
04/09/2012 07:56 PMPosted by Sobaka


You aren't going to have any luck, the services are still down.


They seem to be back up I am able to get into it and go thru with it... it just keeps declining my payments.


It could take a bit to get everything back up to speed.
Hmm.. mine doesn't show on the bank either, however if you go into Character Transfer History in Account Management, it says pending. My guess is it will go through when they're done fixing the system. My impatience has already got me stuck in pending when I should've known better and waited (lol).

Even if yours isn't showing up as pending in Account Management, it might be a good idea to hold off on trying new cards. Just in case. You don't want to get charged 3-4 times like it seems others have. Granted, they should credit you back if you call billing.. but it's always better not to have the hassle. Hopefully there will be an update in the morning.


Understood, yeah I checked transaction history.... The whole thing worked about... 3-4 hours ago. Said pending then said "failed" and asked me to re-submit. That's when it started declining everything I tried.
Just called the dude said still no estimated time >.<
I'm just all around upset with Blizzard lately so every little thing they do seems to peeve me even more, I guess.
Whelp have to go to work soon hopefully this we be resolved in the AM and I don't come back to some (insert choice word[s] here) charges that I have to deal with.
Just refreshed and mine went through alright. It's no doubt gonna take some time to play catchup with all the requests being sent at once when it was made available.

Good luck, Sobaka! If it's still giving you problems when you get back, it's definitely worth a phone call to be sure.
Just refreshed and mine went through alright. It's no doubt gonna take some time to play catchup with all the requests being sent at once when it was made available.

Good luck, Sobaka! If it's still giving you problems when you get back, it's definitely worth a phone call to be sure.


Glad it worked for you!
Yeah I will have to give them a call... I am now just afraid that I am going to be charged a large amount of money that I will have to deal with as well lol... guess we will find out eventually.
interesting turn of events... The toon has been transfered to the selected server but states it is un-playable until I finish the transaction...which is exactly what blizz wont let me do.

Join the Conversation

Return to Forum