updating setup files

Technical Support
hello don't know if this is a issue but I been on updatting setup files for at least 14 hours + is that normal do I need to be out of wow for that any questions ?
bump now its more then 24 hours + plz help i wanna play the beta
i am also stuck. seems to be a prob with a bunch of people. Tried deleting and restarting the MoP setup, but still getting stuck. Blizz hasn't seemed to say anything about it; at least that I have seen
Happened to me too, im a MAC user, Mac OS X 10.6.8, i have restartet my MAC, i vae closed and re open the beta setup app, and nothing. i deled the installation folder from the apps folder, and it worked
Just an update, i let it download the whole night, and i woke up at 12mid night, i got a wowerror and it restarted again it's stuck at "updating setup files"
This is exactly what happened to me, I started the download process when I went to bed last night expecting it to be all downloaded when I got up but when I got to my computer it had an error of some sort, now whenever I try to start again it gets stuck on the downloading setup files thing :(
Stuck on updating files box, has anyone found a way to fix this? Please help.
Hey all, I had the same problem, but I got the game running, go to the file where the beta game is install, than run the game (click on) with the green "WOW" icon, and the game should load, it works for me, just make a short cut and run your beta game with this icon, my "launch" icon still does not work and it will stuck on "updating files" but I don't care I'm playing it now heh.

Good luck all!
I get this too but I can't even install it because its stuck at setup files
same here, stuck at updating setup files
same here stuck at set up files did ok on other computer but not this one lol

Works fine on my fiancee's craptop lol but not on my desktop where I play these damned games!
so, whats the FREAKIN fix, been stuck on this since noon today. done a dozen different things found in the forums and yet it is still updating setup files. maybe the perfect fix is not to pay the next months subscription. pretty bad after 3 years this is the worse its ever been.
im still stuck on this updating files thing and i have idea what to do anymore
Yeah this is bull!@#$ this updating setup files thing is running 50% of my computer's processing power and hasn't moved from under the L for about 3 hours now... what's going on blizz how do we fix this!
Having the same issue. I deleted everything Blizz related on my computer to reinstall. Now both Diablo 3 AND warcraft do the "Updating setup files" only warcraft is only download running for THE LAST 10 GOD DAMN HOURS. blizz turned off their phone system so i cant get help, and they have 48 hours to answer a ticket...this is BULL blizz!!! how many times have you updated this game? how many patches? how many hot fixes? and yet you cannot improve this massive issue that seems to worsen with each expansion.. A LITTLE CUSTOMER SUPPORT BLIZZARD i normal am understanding with blizz and some game issues...but damn near 24 hours of a patch download that doesnt work and client download for your games that is faulty ....someone get on this thread and address these issues
I couldn't get the damn thing to work at all.. tried everything. So, uninstalled and now it's just sitting here trying to "update setup files" .. sitting in the same spot for the longest. WTF Blizz... FIX THIS SH*T
Yeah and I still have to apparently download the patch after this because speakeasy.net says my speed's are not even being used by anything. Not cool to download a 7 gig patch with a 300kbps fu*king connection it takes 7 hours so I still have to wait another 7 hours after this updating setup files crap is done.. if it ever get's done I keep seeing the bar jump about a half inch forward then it jumps back to where it's been forever. It's also running my processor so it's acting like it's froze up or something... FKKKKK THIS!! And I just resubscribed 2 days ago after 4 months of not playing because of boredom!!!!!
Lifegiverr, I understand your pain. I had to download a ~21GB file with a ~450kbps speed.

@OP try this out:

Installation stuck at 0 %

Please try deleting the battle.net folders:

  • C:\Documents and Settings\All Users\Application Data\Battle.net
  • C:\ProgramData\Battle.net
  • [MAC OS X]
  • /Users/Shared/Blizzard/Battle.net
  • **Note** you will need to enable hidden files and folders on your system in order to see the Program Data and Application Data folders on Windows systems.

    Additionally, if on OS X, the older pre-5.0.4 Launcher may be launched concurrently with the newer one. Please switch to this older launcher and close it, and let the re-optimisation complete.
    Nope, same issue. Now at around 8 hours stuck in same spot.

    Join the Conversation

    Return to Forum