Blizzard failed with an internal error?

Technical Support
Hi, I'm on a college campus and I tried to update my WoW, but all I got was:

Blizzard failed with an internal error, please contact technical support.

Now I heard the solution was:

IF you were running the 64bit client, make sure that you delete those files relevant to it.

Battle.net-64.dll
MoxieProxy.dll
Scan-64.dll
Wow-64.exe
Restart the launcher and it should start a repair.

I looked into my WoW folder but I can't find these files. Can someone link to me a directory please? Thanks.
Arakøn

Were you using a 64 bit client before? Not a 64 bit OS, but a 64 bit WoW client. To do so, you would have needed to download the 64 bit files from our forums and paste them into the WoW folder.
________________________________________________
Support Information Administrator
If you can't find a solution to your issue, feel free to contact a Support Representative directly for further assistance. Their contact information can be found at the following link: http://us.blizzard.com/en-us/company/about/contact.html

I'm available on the forums Monday through Friday from 11AM to 8PM Pacific Time
I get this same error, but NOT and have EVER ran the 64 bit client, I am getting this error with the 32 bit client, downloads the small patch, then sits at 0% on applying updates.

Ran the repair tool and the verify/repair tool both did nothing, same issue.
Syniister

Can you post your launcher log for me? You can find it in the World of Warcraft > Logs folder.
________________________________________________
Support Information Administrator
If you can't find a solution to your issue, feel free to contact a Support Representative directly for further assistance. Their contact information can be found at the following link: http://us.blizzard.com/en-us/company/about/contact.html

I'm available on the forums Monday through Friday from 11AM to 8PM Pacific Time

Wow-64.exe
Restart the launcher and it should start a repair.


Hey mate all I did was rename this to Wow and it launched. Tried to make it 64bit again but it just does internal error. Guess us 64bit users can't run it anymore?
Sweet. I have been looking for a while now, trying to find a fix. Deleting the 64 bit files did it.
Well im having errors as well but im not running the 64-bit at all and it just stays at the launcher screen with no updates. the play button is grey and it wont do anything . if i try and repair it for some weird reason it say's connection to blizzard server not found. i don't know what to do now just sitting here =)
04/18/2012 05:22 AMPosted by Whtahealer
Well im having errors as well but im not running the 64-bit at all and it just stays at the launcher screen with no updates. the play button is grey and it wont do anything . if i try and repair it for some weird reason it say's connection to blizzard server not found. i don't know what to do now just sitting here =)

Try what I suggested the person do in the following thread in post #9, and see if that helps you out.

http://us.battle.net/wow/en/forum/topic/4488639199?page=1#8
I'm almost 100% sure i did not do anything close to whats being described for the 64-bit data, and the fact those files are also not there, just confirms my own suspicion. I too am recieving the exact problem. My internet here isn't the best, however it clearly works... I'm sending this from it. I was just on last night, and now today, i can't get on. Not sure how it will help, but this is the error log.

#-----------------------------------------------------------
# System started at 2012-04-18 10:58:54.8454
# system: (secured for my protection)
#-----------------------------------------------------------
10:58:54.9731 Launcher version 4.2.1.2736
10:58:56.3679 World of Warcraft version 4.3.3.15354
11:00:04.9957 Starting PatchOnDemand system...
11:00:04.9958 Retrieving torrent information from the server.
11:00:06.2409 Failed to download new torrent file from 'http://blizzard.vo.llnwd.net/o16/content/wow-pod-retail/NA/15050.direct/wow-15595-1D5153E3CE003B4734AF95852EA119AA.torrent'.
11:00:06.2409 HTTP error downloading new torrent file from 'http://blizzard.vo.llnwd.net/o16/content/wow-pod-retail/NA/15050.direct/wow-15595-1D5153E3CE003B4734AF95852EA119AA.torrent' (0).
11:00:09.4830 Failed to download new torrent file from 'http://blizzard.vo.llnwd.net/o16/content/wow-pod-retail/NA/15050.direct/wow-15595-1D5153E3CE003B4734AF95852EA119AA.torrent'.
11:00:09.4830 HTTP error downloading new torrent file from 'http://blizzard.vo.llnwd.net/o16/content/wow-pod-retail/NA/15050.direct/wow-15595-1D5153E3CE003B4734AF95852EA119AA.torrent' (0).
11:00:10.2974 Failed to download new torrent file from 'http://blizzard.vo.llnwd.net/o16/content/wow-pod-retail/NA/15050.direct/wow-15595-1D5153E3CE003B4734AF95852EA119AA.torrent'.
11:00:10.2974 HTTP error downloading new torrent file from 'http://blizzard.vo.llnwd.net/o16/content/wow-pod-retail/NA/15050.direct/wow-15595-1D5153E3CE003B4734AF95852EA119AA.torrent' (0).
11:00:12.9562 Failed to download new torrent file from 'http://blizzard.vo.llnwd.net/o16/content/wow-pod-retail/NA/15050.direct/wow-15595-1D5153E3CE003B4734AF95852EA119AA.torrent'.
11:00:12.9562 HTTP error downloading new torrent file from 'http://blizzard.vo.llnwd.net/o16/content/wow-pod-retail/NA/15050.direct/wow-15595-1D5153E3CE003B4734AF95852EA119AA.torrent' (0).
11:00:14.2840 Failed to download new torrent file from 'http://blizzard.vo.llnwd.net/o16/content/wow-pod-retail/NA/15050.direct/wow-15595-1D5153E3CE003B4734AF95852EA119AA.torrent'.
11:00:14.2840 HTTP error downloading new torrent file from 'http://blizzard.vo.llnwd.net/o16/content/wow-pod-retail/NA/15050.direct/wow-15595-1D5153E3CE003B4734AF95852EA119AA.torrent' (0).
11:00:14.2840 Torrent failed to download. User's Internet connection may not be working.
11:00:14.2841 Torrent failed to download. User's Internet connection may not be working.

I've also tried disabling all my firewalls and turing off my avast. Also tried booting to safe mode with networking, and still no dice. Unless something changed with my public access provider (i'm deployed in the desert, can't get around that).
04/18/2012 05:56 AMPosted by Forcemage
I've also tried disabling all my firewalls and turing off my avast. Also tried booting to safe mode with networking, and still no dice. Unless something changed with my public access provider (i'm deployed in the desert, can't get around that).
They're blocking torrents. You can get around it downloading the current WoW.tfil file:
http://patchup.info/tfil/NA/
Download and extract into your WoW folder.

-

And OP, delete the Updates folder.
Your a rockstar Barthus, after dl'ing this file, then running in safe mode, i'm upt to date and ready to play again. Thank you very much... you to Maeleena, for your safe mode idea.

Join the Conversation

Return to Forum