[Solved] Unable to Login to Moble Armory

Mobile Bug Report
Does this all affect the Android version? It seems to disconnect quite frequently. Often times mid chat or as soon as the screen turns off.

Running on a Droid2 Android 2.3.4 Wow and Acer Iconia A100 running Android 4.0.3. Both running WoW Armory 2.3.0

Also, I was having these same issues that are all started above. Failing to connect, server not found, check the firewall settings etc.
This thread addressed a different issue altogether. What you're describing is a separate issue related to maintaining a Guild Chat connection. We are aware of some outstanding bugs with the latest Android Mobile Armory, particularly with returning to Guild Chat after the window times out or is locked.

As for stability, we have not encountered the reported stability issues outside of an issue with the realm Moon Guard. We have an abundance of devices with various OS's and carriers, yet we have not seen any of this general instability.

So here's the plan:
1. We work to identify where the Guild Chat instability issues are occurring.
2. We roll out a hotfix for the screen timeout/lock issue.
Is there a timeline or updates regarding instability and time out issues?
yup be nice if it wouldnt auto log out. right now i just have my phone to never go to sleep and lock that way i can set it down and come back.. kills my battery though
I have tried loging in an I have been having the same problems
On my iPhone 4gs . It will not log me in.
I am still getting these errors on my iPhone 4s and iPad 2.
I'm paying for this Monthly . Is this issue going to be solved ? .
still happening to me often, i can use the guild chat feature only sometimes most often it says it cant connect or some crap like that and i have asked ppl with it and they are having the same problem fix it ffs
This has not been solved at all. I have been having this problem for over an hour what was solved?
I am now getting this connection error for the first time. I updated yesterday and have been using the armory all day. Around 9pm est, I lost the connection and won't reconnect. Have reinstalled the app and checked my router settings. Any eta on when this will be corrected?
I am having the same problem. Started about 3 or 4 hours ago.
I am having the same problem. Started about 3 or 4 hours ago.

Please sovle this!!!!!!!!!!!!!!!!!!!!!!!!!!!!
iPhone 4S-4.1.1 OS-latest armory update 24 hours ago. This started happening to me about 6 hours ago and still going strong. Just a future note to others. I'm not sure, but I think it helps blizzard fix the problems faster if you explain what you are using. As in, Android, IPhone, and listing the OS you are using wouldn't hurt. Hurry Blizz!!! I need my AH fix!!! Lol
still not working, just in case this info matters i am using an iphone 4s with 5.1 updated ios and the 3.3 updated wow armory, the server is saurfang. cant get past the log in screen and says connection failed or that my port may not be opened for it whether i am using 3g or wifi. Pls get it fixed
I have also been having this issue all day some of yesterday. Connection timed out and won't log in. IPhone 4 running iOS 5.0.1. Please blizzard I wanna sign up for the guild stuff but I can't do it if I can't use the app.
As of 5/13/12 @ 12:35 AM EST still having problems logging in using IOS 5.1 and updated mobile armory client.
Mine was working earlier today (may 12) and now on my ipad2 or 3GS I get the same connection to the server failed.

iOS 5.1.1, iPhone 4, current mobile armory patch armory. Get a message that "login failed" for the Americas and Oceanic, but can log in to the Europe and Korea armories (have no characters there).
I did initiate a paid service today, I transferred a character, and the armory issue started at some point after the transfer went through. In fact my name plate here reflects the guild I was in before I transferred characters.
Details helps Blizz pinpoint, I say this because of my earlier post. I'm no program whizz, but even I can see that thanks to descriptions, this is an iPhone only issue. I'm sure Blizz noticed this an hour ago. Thanks for the details. I'm just as bummed that it's not working as all those who posts. Details help pinpoint problems, my wife just doesn't understand that philosophy.

Join the Conversation

Return to Forum