armory not updating.

Website Bug Report
I really have no idea where to inquire about something like this, but i am trying to gear up my holy pally spec using askmrrobot, but i logged out and back in and refreshed it and the page didnt change, so i repeatedly logged out and to other characters and still the same, so I checked the armory, my character has not changed to the gear/spec that i am currently in. If anyone knows how to fix this, it would be much appreciated.
Have you logged out of the game before doing this?

If not, sometimes the armory is just slow, and takes a while to update :(
yes i logged to my mage for about 10 minutes thinking it might be just slow to update today for some reason, but that didn't help
Have you hit the Reload button? Not the browser's Refresh button, but the actual Reload that's on the Ask Mr Robot website?
the armory still hasnt updated me as being in holy spec, i know why mrrobot isnt seeing me in holy, the armory is the problem :(
my character still hasnt updated on the armory... very strange.
Mine hasn't updated since last night, about 8 hours ago. Armory is not updating, despite having been logged out for all that time.
none of my toons are updating either. Please fix !!
Come on blizz! I need this to work before my raid tonight!
None of my toons are updating either. A fix would be nice. Not all of us appreciate you messing everything up for diablo.
There is no FIX for this.

This is the way of the armory, has been since day one. Can take 2 mins some times, and other times 2 days.
this should be posted in either the website bugs or features forum. CS forum is for in game issues not anything to do with website stuff. Sorry. They wouldn't be able to help with the issue nor give an update about it.
I've been having the same issues since upgrading some gear, hasn't updated since thursday.
Yup not updating today looks like - went in to check kills and achieves and none of the ones completed yesterday are on there. Probably due to the Diablo 3 frenzy - don't know why an internal system shouldn't be doing its job unless they turned it off to slow down access to the servers. Probably not the best idea since you will get constant requests from 3rd party sites anyway.
There is no FIX for this.

This is the way of the armory, has been since day one. Can take 2 mins some times, and other times 2 days.


Thats bull. 2 days for a service WE pay for! I have never had to wait 2 days at most 2 or 3 min. This is bull BLIZZ get off your a##'s and fix the game WE PAY FOR!
This is in fact a bug and I am seeing it as well on my alt. It has been over 24 hours since my character was updated and I have logged out/shut down WoW several times since then. I am fully expecting blizzard to come out of the woodwork acknowledging this and providing a fix as soon as they can. Just be patient.
Log out in outlands. Updated me the second I logged off.
There is no FIX for this.

This is the way of the armory, has been since day one. Can take 2 mins some times, and other times 2 days.


Thats bull. 2 days for a service WE pay for! I have never had to wait 2 days at most 2 or 3 min. This is bull BLIZZ get off your a##'s and fix the game WE PAY FOR!


Calm down. You are getting what you paid for.

THE GAME AND THE SERVICE ARE PROVIDED ON AN “AS IS” “AS AVAILABLE” BASIS, AND BLIZZARD DOES NOT WARRANT THAT THE GAME OR THE SERVICE WILL BE UNINTERRUPTED OR ERROR-FREE, THAT DEFECTS WILL BE CORRECTED, OR THAT THE GAME OR THE SERVICE ARE FREE OF VIRUSES OR OTHER HARMFUL COMPONENTS.
There is no FIX for this.

This is the way of the armory, has been since day one. Can take 2 mins some times, and other times 2 days.


As someone else said, log out in Outlands. It worked for me as well. It might not be Outlands specifically, it might be any area outside of a major city.
05/19/2012 10:11 AMPosted by Soulplane
Log out in outlands. Updated me the second I logged off.


Worked for me. Thanks!

Join the Conversation

Return to Forum