Unable to log into remote chat recently

Mobile Bug Report
Since about 3 days ago, my character has been unable to log into the remote chat on the Armory app. When I log onto my other characters in game, they can see the character in guild as if it is in remote. I send myself a whisper and I receive a push notification even when I am logged out of the armory.

The other features of the armory are working. Any time I try to log into the chat, it attempts to connect and tells me that it timed out. I have tried logging out and turning off the phone, untinstalling the app- restarting the phone- and reintstalling, and I have also tried logging into that character in game- accessing the remote auction house on that character to boot it out of remote. Nothing so far has worked.

If anyone has other hints or things to try, I would be happy to hear it.
I've been having the same problem too recently, though I haven't done more than reboot my phone or the app. I've been waiting patiently since it started a few days ago, but it hasn't been fixed yet. The delay in fixing it probably has more to do with the holiday weekend than anything else.
Something else to note, whenever I try to switch characters within the app, I can access the auction house for that character, but it never acknowledges my logging in on the in-game roster. Whenever I log out of the app and back in, I am on the character that is locked in the remote chat.
After the server maintenance on Tuesday (today), the Armory app and login behavior returned to normal.

This is good news, but I feel this situation may show up again. It will be unfortunate if I have to wait until a point of server maintenance to recover functionality to the remote chat.
Okay, now that it is one day after the realm maintenance, I have the same problem once again beginning some time after 9:13am.

Is anybody else having this issue now?
This isn't just affecting a particular realm, it's a pretty widespread issue right now. We should have the bug pinpointed soon.
Not able to log into US/Oceanic server. Been having this problem periodically, but has been down most of today :(. I would really like to get this fixed soon.

Join the Conversation

Return to Forum