ToC (Raid) Faction Champions Bugged

Bug Report
I thought this was just a freak occurrence until it happened a second time to me tonight. In Trial of the Crusader when you start the Faction Champions encounter, after all the talking is done, no enemy players jump down. This first happened about a month ago. I'm not sure if this is only bugged for Alliance but I would assume not. Nothing seems to be a direct cause of this, it just happens at random. I tried switching the raid difficulty but it says unable to due to an event in progress. Only option seems to be to hearth out and wait for a soft reset.
Just happened to me as well. I am aware that this is a necro, but the exact same issue still exists.
(ONE YEAR LAAATTERR) Just happened to me.
2 years later, this happened to me. WHAT IS GOING ON!!!!??
this just happened to me as well, would think that after this long it would be fixed...
Same just happened to me. :/
Just happened to me.
Sorry for the necro but wtf this is still going on.
its bad enough that nothing drops but to have your chance taken by a glitch?
Well hey look at that, just happened to me too. Nearly three years later.
Five years later.. keep it goin. Weeeeeww
And now it has happened to me :(
Just happened to me still isnt fixed LOLOL
Just had it happen to me as well. I'm surprised that there hasn't been a resolution to this problem. I know it's an old raid, but it does kill progression in the raid.
Well I guess it's good to know I'm not the only one...still this bums me out
Still happening.
Just happened to me.
Hate to necro this thread, but it just happened to me as well. :(

So I guess this means I'm locked out of progressing until it resets next week?
Thought I was going to have to necro the thread. Then I noticed it had been done already.

4 years later and still not fixed.
weird... i literally just did this with no problem and have been doing it for last three weeks. :/

maybe provide some more details like what difficulty, realm, etc.

Join the Conversation

Return to Forum