Quest BUG - "To The Rescue"

Bug Report
The HORDE quest: "To the Rescue" located in Ashenvale; seems to be bugged far worse than it used to be.

You used to be able to initiate the quest then half way Brutusk (the kodo) would get stuck and you wouldn't be able to continue, to fix that all you had to do was /reload.

Unfortunately now when I try to complete this quest I can't even mount Brutusk, says hes "watering the bushes" or something like that.

Is this going to get fixed? Currently TRYING to get Loremaster but this is preventing me.
There are multiple threads regarding this issue, and a few of them have posted workarounds.

You may be unable to get the quests achievement for Ashenvale if you do not complete To the Rescue!. It is a direct prerequisite to several quests, and an indirect prerequisite to others.

From what I've heard, if Brutusk is watering the bushes, you need to wait. If possible, you can also log on as soon as maintenance/rolling realm restarts completes on Tuesday, and try doing the quest then. I've heard a theory saying that if Brutusk is watering the bushes, it implies that another player has already started the quest but has not completed it.

I recommend digging around these forums a bit for some information and workarounds. I've leveled several toons recently, and I've never had a problem with this quest. I do wish I could help you more, but not having experienced this myself, I'm at a loss.

Here are some recent threads on the issue:
This is ridiculous. I can't even complete it. Its driving me nuts.
Yup, it's still not working and I have 2 toons that need this. Why isn't this fixed yet?
I am having he same issue. I don't have any other quests available until I can get this completed.
Yeah definitely not working on Kil jaeden
its not working for me to! i am soo mad!!!!!
This quest really ticked me off! I finally made soon as I got hung up on the path I logged out, logged back in, spoke with Kadrak again to start the quest. It finally completed the quest. It may take a couple of tries at this but it finally worked for me.
Yup it says he "watering the bushes" LOL but its not coming back and let me do it what do i do? im a little annoyed..
Logged in an out 10 times. No dice. Stupid lizard beast is still watering the bushes.
Holyskizz is getting upset!

Edit: I was finally able to get the kodo to stop taking a leak by killing the questgiver and the kodo with my ally character, but then I got stuck at the first roadblock and had to abandon the quest and relog. After that I picked it up again and was able to finish it.

I love how this is a low level quest too. A good way to get new players acquainted with the game.
I too had problems with this quest, i was 40 / 62 quests completed to get the ashenvale achievement. I had to log onto an alliance toon as well and kill the quest giver Kalrak as well as the kodo Brutusk die then log back into my mage to get the kodo to stop "Watering The Bushes"! This work around is possible.
need help with that bug guys
Same the bug is still out there and I guess they dont wanna fix it GRRRR!!!
Just had the mission, and it bugged. Tried logging and that didn't work. I abandoned the mission and tried something I read on wowhead - accept the mission, take off all equipment & weapons, and then talk to Kalrak to get on Brutusk, That worked, and the mission went through to completion.

Hope this helps.
I'm stuck at the part where the lady rides back with you and dies. I talked to Kadrak to complete that quest but when you have to go back and talk to him to do the next part he keeps telling me that Brutusk is out watering. Been like that for about an hour. Am i missing something?
Omg this is so frustrating!!! Trying to get my Loremaster achievement but cant get any quest from ashenvale because of this bug...
got stuck twice and then I removed all armor and weapons and it worked.
I removed all the armor on my orc but when i clicked on Kadrak all it says is "Work complete!" and won't let me lick the continue button... Help??

Join the Conversation

Return to Forum