Unable to logoff?

Mobile Bug Report
Ok, as of early this morning, Xyer is finally offline as is ONE of the other two that were in the same state. I uninstalled the wow armory app, took out my sim card, memory stick, and battery from my phone, put them back in and then reinstalled the updated version.

I'm not sure if that was what solved it, if it was a coincidence, or if you guys were able to do something but that's the update.

If the problem happens again, I'll come back and update the thread with any other thoughts.

Thanks a bunch for working on this issue.

Thanks for the info. We still have not encountered this particular state without the use of a second device, but the possibility that it resolved after stripping your phone of it's sim, memory card, and battery is good news in that we have a potential solution for other players. (If anyone else encounters this, please try and eliminate one of the steps to narrow it down. I'd try but I cannot get into the state in the first place.)

It's also possible that, --for lack of a concise term -- the "instance of your character's mobile away status" simply expired. I'm fairly certain this is what happened to the OP, otherwise there'd be plenty more replies on this thread. How long has this been going on with that character? If it's >= 2 weeks, the chances of the status expiring are greatly increased. (The expiration of the status is not a set value, but 2 weeks is the average time.)
I'm also having the same issue. I only use moble armory on my Samsung Epic 4g.

Before Sunday nothing was wrong. On sunday, while I was checking auctions, I decided to pop into guild chat and see who was on. I exited chat (I hadn't used the chat function in a while). After doing my auctions I realized I was still in chat, so I reentered chat, and selected "offline". When I signed in for raid sunday night, I was told that I had been on all day (and not answering.)

Since then, I've entered and exited the app, I've logged onto and off of Ichthos in game. I've shut off my phone, and I put in a ticket, and was sent to this forum.

Ichthos still shows as on, and apparently, lots of people try talking to me when I'm not on.

When I sign into Ichthos, his guild status switches from remote to where he's at, and when I log out, guildies see me log out but the guild pannel still shows Ichthos there on the remote again. :(

I hope my added information helps. I only log onto my account from that one android phone and my windows desktop.
More information. I can chat both on the phone and in game at the same time. If I'm signed into ichthos on both, both look like they are chatting from the same place. But, what I type in game doesn't show up on phone chat (though what others type shows in both locations).

I decided to try switching what character I was using in remote, and right now, I'm on Drakk in game, on Liebs on remote chat and on Ichthos on remote chat. :/

Liebs was able to log out just fine, but Ichthos ghost is still there. *sigh* more telling guildies that I'm not ignoring them. Here's hoping restart in morning clears it. :)
We're still working to identify this bug. Is this still happening since the restart?
I have been having this issue as well as 2 others in my guild exactly the same. i even had the app FULLY REMOVED from my phone and yet i was still "online active on remote" according to guildies for about the last 8 or 9 days. one of my guildies had been constant for almost 2 weeks now. the other about 5 days and counting. i am reinstalling the app again now to try see if anything changes.

PS - have just reinstalled app after turning phone off and on then a clean install and now i have FINALLY logged off on remote (as in, in game logged off).
It's pretty rare to get into this state. Our QA and Dev teams have still been unable to reproduce this issue. However, it looks as if a combination of uninstalling, powering down the device, restarting, and then reinstalling is a potential solution.

If this doesn't work, pulling out the battery, sim, and/or memory card after powering down should be the next thing you attempt.
i logged on last night and the chat was not working
and this morning the toons i used to try to chat with are still online
i have tryed logging out , makin the toon offline on the remote chat and logging on to that toon in game then logging out nothing working tryed removing it off my itouch and puttin it back on too
i logged on last night and the chat was not working
and this morning the toons i used to try to chat with are still online
i have tryed logging out , makin the toon offline on the remote chat and logging on to that toon in game then logging out nothing working tryed removing it off my itouch and puttin it back on too

Take a look at the potential solutions in the posts made prior to your own. Let me know if any of those work for you.
Ok, I have an iPhone 4S with the latest version of the Armory.

This character is having the same issue, isn't being logged out of remote chat.

I have logged into remote chat and logged out, no joy.
Logged in and back out, removed the app, turned my phone off entirely - no joy
Re-installed the app, logged in and out - no joy
When I log this character on, the remote icon disappears next to my name on the Guild roster, but as soon as I log out it comes back.
I logged on a different toon in the same Guild, showed he was logged on remotely in Guild roster, logged him out and refreshed the Guild roster and he is not logged in.
So the problem seems to be to this character only.

I have checked my other my Wife and Daughter's iPhones and they do not have the Armory installed.
Have you attempted uninstalling, then powering off the device, powering on, then reinstalling?
See previous post, 3rd paragraph, 2nd and 3rd sentence :-)
I am also having the same problem and have tried all the fixes suggested in this thread and still show as online. I used the remote chat for the first time on Thursday and haven't been able to log out, ever, even though I log out of the app. I can not even log in to guild chat on my iphone now either, I keep getting the time out error. Has there been any further fixes found? Other than the complete uninstall and turning off of phones etc?
I'm on an Iphone 4, i can't really remove my battery, but i have uninstalled the app, reinstalled it, powered off my phone, and now i have 2 charecters stuck at online with the remote chat icon beside their name's.
I'm in the same boat. I have an Iphone 4S. I've deleted the app, rebooted the phone. reinstalled the app and it keeps me logged in. I'm not sure how to go about removing the settings from the phone after I deleted the app.

I can sign in as my toon (on the app) but it will not allow me to sign out.
Same here droid razor is what im using Verizon network and the phone is not rooted also i do not have a second device. I was told that both my main Thor and my bank alt are being shown as online mobile chat. I did the usual go offline then uninstall restart thing. nothing so far both are online and i can log into a 3rd toon on the same account and still show them as online. Even better
Same for me. I can log in, I can't log out. I've tried logging in with the mobile client and disconnecting, but it has no effect. I forced the app to close and no effect.

Logging into the WoW Client with that character, then logging back off, with the app closed, still results in me being 'logged in via remote chat'.
I have a feeling that tomorrow's 5.0.4 patch will probably knock all of our sessions offline.
I am also having this problem on a ipod touch. I logged out, I turned off my Wifi, and even deleted/reinstalled the app. Two of my toons are stuck on the mobile app. My friend who has an iphone also has had this problem for months, his toon is always online on the mobile app.
I've had this problem for a couple of weeks now. I have an iPhone 4s so removing the battery is kind of an issue. Odd thing today, this toon was afk for 10+ hours but remained logged into the game.
Same issue

Join the Conversation

Return to Forum