Screen Capture

Customer Support
I am trying to screen capture my game, however when I press print screen the correct yellow wording comes up saying 'Screen Captured', it however does not save it to screenshots. Also, if I try to copy it into paint, when I paste it it is actually a picture of my desktop, as if my print screen was a print screen of my desktop, however I am in wow and the notification text does pop up and say 'Screen Captured'.

Any ideas?
Windows 7 64 bit if that helps.
Look under your user documents, not in your wow folder. Sometimes in 64 bit, it saves your screen shots to the User area.
Checked there, wasn't anything in user documents, pictures, etc etc. No where under the user document filepaths.
In windows 7, when you install your game to the default program files directory.. i beleive it puts all the stuff under users > public > games > world of warcraft

Or something like that.
Thanks, but the directory isn't the problem, it's not going in the directory that is. Not even sure it is capturing correctly.
I'd help if I could, but this is more a tech support issue. I suggest posting over there.

Good luck!
06/20/2012 06:30 AMPosted by Null
Thanks, but the directory isn't the problem, it's not going in the directory that is. Not even sure it is capturing correctly.

Actually, you probably are looking in the wrong place. The WoW client does not have any problems taking screenshots and it is a fairly simple process. There really is nothing that can go wrong.

If you normally launch WoW via a shortcut, right click it and select "Open file location". Check to see where your WoW is installed. If it is installed in your Program Files directory and you are using Windows Vista or 7 it should be where Reenela stated -

C:\Users\Public\Games\World of Warcraft\Screenshots

That is, if your Windows is installed on C:
Sorry Maul, might be hard to believe, but read post one. The screenshots are not there.

If anyones got an idea that would be great thanks. But the filepath is not the problem, unless it was like Kozz's idea. Finding the WoW directory, and henceforth the screenshots, is not the problem. The problem is there are no screenshots in said folder.
Cheers Teliah, I googled searched it and someone else had posted in this forum so I just created a new thread, :P I'll pop on over there.
Then, right click the icon you normally start WoW with and select "Run As Administrator". Take some screenshots and look again in the Screenshots folder.

The mechanism in the WoW client for taking screenshots is not the issue. Either WoW is being denied permission to write them to the hard drive or they are being saved in another location.
I always run as administrator. Doesn't work. I'm doubting WoW is even getting access to them at all, because with most instances of WoW, you screenshot it will go to your folder, but also you can still copy and paste into paint and it will be there. Neither is happening. I'll take this to tech support.
I found a few old posts in tech support when I did a search that gave some helpful information. You should try this stuff. You might need to turn on hidden folders. You could have multiple folders for the same thing and you are looking in the wrong one. There also can be issues when you upgrade your windows or move you wow location and that can cause cross or duplicate files. It is very possible to have more then one screen shot folder or simply where it is at is hidden.

For Vista/7 Users, if the game files have been moved to the C:\Users\ folder following the 3.0.2 patch, then the screenshots will be in the folder C:\Users\Public\Games\World Of Warcraft\
If the game is still installed to the default C:\Program files folder, due to extra security on the system the screenshots will be saved to the following folder:
C:\Users\*your Windows user name*\AppData\Local\VirtualStore\Program Files\World of Warcraft\Screenshots\

You may also have to turn on the ability to view hidden files as the AppData folder may be hidden. Click the Start/Windows button, select Control Panel, Appearance and Personalization, Folder Options. Next click on the View tab, under the Advanced settings, click Show hidden files and folders, and click OK to finish.

Note for Vista/7 users: If you have a World of Warcraft folder in both the C:\Program Files\ and C:\Users\Public\Games\ locations, please check to see if one of these locations is empty or simply has a WTF, Cache and/or Interface. If this is the case, delete the folder in question. Now navigate to the alternate folder, right click the WoW.exe file, and click "Run as Administrator". This will help Windows identify where the game is located and will allow screenshots to save appropriately.
Thanks Tink, none of them worked. The last one I thought maybe because I had an uncompleted install of MoP beta in another folder, thought it might of been conflicting. Deleted that, restarted, etc etc. Still nothing. :(
Just gonna call it a night. Thanks for the ideas I'll try again tomorrow; it's not a big deal just wanted to email a mate my UI. Have a good night all.
Are you using a wireless keyboard? Or a keyboard with a function lock ability? Is it turned on?

Or, the last thing I can think of it is a Windows 7 issue. If it is -

-> Right click on the WoW shortcut icon

-> Click on "Properties"

-> Click on "Compatibility"

-> Under "Settings", click on "Disable Desktop Composition"

Then apply changes.
06/20/2012 07:16 AMPosted by Null
Thanks Tink, none of them worked. The last one I thought maybe because I had an uncompleted install of MoP beta in another folder, thought it might of been conflicting. Deleted that, restarted, etc etc. Still nothing. :(

YW, I wish I could help more on this. One other suggestion is are you running the game with the 64bit client? if so you might want to try taking those files out and doing without the 64bit. That client is still technically unsupported so that makes me assume there will be issues and problems.

Another thing I read in my searching of this issue. A few people reported having this issue, they deleted the screenshot folder, then when the game relaunches it recreates the folder and then starts saving correctly. Like maybe somehow it got bugged.

Other then that you will want to post in tech support probably for further help on this. Make sure to let them know your operating system. Also I would put in detail the stuff you have already done. This might help them from just posting what I have already cut and pasted here.

I have kind of a similar issue - i am able to take screenshots of regular game via print screen button, and they do show up in the screenshots folder. However - when i try to screenshot capture the loading screen during a port process, or the character screen - that does not work. It does not show up as a regular screen capture via MS Paint / paste process either. I have Windows 7 64-bit.

Interestingly - this all worked fine before Pandaria. Since i upgraded to Pandaria it does not work now. That's the only thing that changed on that workstation. Regular game shots - yes; loading screen / character load screen - no.

Any ideas are welcome! Thank you for any help! :-)
Yeah this was happening to me, just go to your :C > Program files > World of Warcraft > Screen shots. And all the screen shot you took should of automatically xfered to that file.
Roacha this post was from a month ago. It is safe to assume the issue has been resolved as there is not another post. Please do not post on old threads. This one has been necro'd several times. It is against the rules of this forum. Simply because old threads often contain out of date info.

Join the Conversation

Return to Forum