Armory - Guild 6+ months out of date

Mobile Bug Report
This effects both the site and the mobile app but the site forum hasn't had any sort of response in a few days, so I'm adding it here:

Usually I'd wait and assume it's delayed updating - as that's the fix I commonly see posted.

However, for the past 6 months or so, the Armory hasn't updated the roster, level, or perks of the guild - the only thing it's updating is the Recent Activity.

It's kinda weird seeing activity in the guild for members who apparently aren't in the roster.

This is the Armory page.

In game it's correct however, a much different roster (More members have joint), and we're currently a level 5 guild.

Any reason this hasn't updated in roughly 6 months+?

A few hours or days I can understand, but not updating in 6 months is just bad.
Thanks for the report Syreania. We'll take a look into this ASAP.
Any update on this? Still not updated at all.
Ok, now the guild doesn't even exist apparently. (Armoury, mobile armoury give me a 404 - still works in game though). Been over a month since I've had any information on what's happening.
Any feedback at all?

6 months of no update, and now it's still 404ing on the mobile and website armoury.
Still not a word or anything, and still not working. Coming up to 9 months out of date now.
This bug was not able to be resolved, so it's been escalated for a more thorough investigation by the WoW team. Our web and mobile services have been rapidly expanding this year, so this feels like growing pains. I'm doing everything I can to make certain your guild issue is not forgotten and is followed up on.

That goes for all individual character and guild issues reported on this forum. It can take just as long to figure out these individual character issues as it would to implement a new feature. It may seem like very simple data, but it's going through a very complex system.

Sometimes we get reports for specific issues like this that we've never seen before. Yes, missing guild data seems fairly common, but the way in which it is manifesting... we've never seen a specific problem like this before that wasn't easily resolved.

I'll keep you updated. I've sent reminders to everyone involved in resolving this reported issue.
Syreania, we finally pinpointed the bug that affected your guild. Apparently your guild was one of 2 guilds experiencing this problem. The bug is now fixed and your guild should be displaying properly now.
Yup, all working now. Must've been a pretty specific / odd bug o.O

Still, yay!

Join the Conversation

Return to Forum