Error handling this request

Mobile Bug Report
Greetings! The iOS Armory App all of a sudden is displaying the message "The Armory encountered an error handling this request." every time I try to log in or open it. it's not just once, it's every single time for a week now.

And if I go to view a character or whatever, bamn same error and boots me out.

I'm running 3.3 on iOS 5.1.1, iPhone 4S.

This was likely a temporary issue. I encountered it myself on Sunday, but it has since been working without any problems for me using the same device and OS. Let me know if you're still encountering this error.
Having the same problem for about the last week. Every time I try to login, I get the same error message, "The Armory encountered an error handling this request." I get the same error whether I am on my home network, my work connection, or using the 4G on my iphone.

I have an iphone 4S with the iOS 5.1.1.

Any help would be appreciated.

I have been having the same problem on my iOS devices. I have a iPhone 4 and a iPad 2 both with all updated software and apps. I tried being connected to both my Wi-Fi and 3G network. I live in Canada and have been having this issue for over a week now.
Same problem, even kicking me out of guild chat when I switch to Auction House. It's been happening for the past 2 weeks. IOS 5.1.1 and armory 3.3.0
I have the same problem but it only started today after I upgraded to the paid subscription. Help would be appreciated!!
This same problem just started for me today... any assistance would be greatly appreciated.
I have been having this issue for about a week. Samsung 3.

Join the Conversation

Return to Forum