Retina Macbook Pro performing badly

Mac Technical Support
i have been trying to play WoW as well as SC2, both have been giving me problems when it comes to the games frame rates. I do not play on 2880x1800, I usually try 1680x1050 or 1920x1200 and even have had it on low settings and my fps is fine and dandy doing absolutely nothing, as soon as I enter combat, my fps goes below 10. I barely even hear the 2 fans running and have it set to use my Nvidia Geforce GT 650M. I know on my previous computers the fans used to blast and I had better performance on an old Macbook Pro with a 9400M (3 years old).

Please help!
Did you disable automatic graphics switching?

Was your installation of WoW/SC2 a fresh install or was a transfer through Migration Assistant/Time Machine?
07/16/2012 09:07 AMPosted by Machkhan
Did you disable automatic graphics switching?


That would force it to use the dedicated gpu so no problems with that.

@OP did you try turning shadows down? I used to play on 1920x1200 on ultra with shadows turned down and got ~40 fps. Now I just play at 1440x900 with an almost constant 60 fps. You can download istatpro and use it to check your fan speed under load to see if there is a problem with the hardware. Usually my fans are running at around 4800-5000 rpm while i'm raiding 25 man DS.
I have a MBP Retina and I haven't had any issues w/ frame rates at all...all my issues are w/ the UI at high resolution. I would exchange your MBP if you keep having trouble
I have a retina MBP also, and I suddenly got the screen-rate issues yesterday. I went from very playable (I have been playing with everything set to Good in native resolution) to 4 fps. I assumed that it was an add-on or some such issue, of course, so I turned all but the 5,000,000 I can't live without and still had really bad fps.

I tend to exaggerate, with the 5,000,000 comment.

Anyway, I tuned the slider down to Fair and was able to get maybe 24 fps while questing which would drop precipitously in dungeons.

I came to this thread and did the SMC and NVRAM resets, went back into the game, and then had 100 FPS on fair and 50ish on good.

So the resets helped; admittedly, I just did both and didn't try doing just one. I wonder why it happened, what screwed the settings up. It seemed strange to me because it didn't coincide with the patch, exactly, since I wandered around Pandaria for a couple of days before the screen rate went to $#it. But it's much, much better now, even with a bunch of addons.

Happy to post my Mac's specs if need be, but seeing as how there's so little variation in Macs, I don't know that it would help. This is a Retina MBP with 16GB RAM. I'm just happy it helped, though I wonder if it'll crop back up.

No MacOS patches went through, nor was the game patched other than potential server-side hotfixes in this time that I'm aware of. I'll report back if the screen rate drops again, but I know the first thing I'll try is to reset the SMC and NVRAM.

Stuart
07/16/2012 11:50 AMPosted by Domipal
Did you disable automatic graphics switching?


That would force it to use the dedicated gpu so no problems with that.

@OP did you try turning shadows down? I used to play on 1920x1200 on ultra with shadows turned down and got ~40 fps. Now I just play at 1440x900 with an almost constant 60 fps. You can download istatpro and use it to check your fan speed under load to see if there is a problem with the hardware. Usually my fans are running at around 4800-5000 rpm while i'm raiding 25 man DS.


How did you get WoW to run at 1440x900? I just see these ridiculous unconventional resolutions.
09/28/2012 10:09 AMPosted by Hordechewer
How did you get WoW to run at 1440x900? I just see these ridiculous unconventional resolutions.


I'm in the same boat! I would love to run my 15 inch retina mbp in 1440x900 but I have either native (which sets the fan off like crazy after a few minutes) or odd resolutions that blur the text and are sloppy looking.
I have found that a simple SMC reset can cure framerate issues, especially since the last EFI update.

1. Shutdown the MBP.
2. Plug in the power cord if it isn't already connected.
3. Press the left-side Shift, Control, and Option keys together, then press the power button. The laptop should not power on - if it does, you didn't hold down the right keys.
4. Let go of the keys. The LED on the MagSafe adapter should change colors.
5. Now press the power button to boot.

Join the Conversation

Return to Forum