Focus/Mouseover Macro help

UI and Macro
I am trying to add a focus modifier to my mouseover macro that will cast Riptide(or other spells) based on the following priority:

Heal focused target if SHIFT is held, and can be healed
Heal mouseover target if they can be healed
Heal target if they can be healed
Heal myself if none of the above is true

Everything is working fine, except for the Focus target healing. Holding down SHIFT is having no effect whatsoever.

I have tried moving mod:shift, before @focus, and even after nodead but that doesn't have any affect either.

Hear is my current macro. Any help would be greatly appreciated.

/cast [@focus,mod:shift,help,nodead][@mouseover,help,nodead][help,nodead][@player] Riptide
You have shift + your key bound to something and/or have shift set to your focus/self cast key in the Interface menu.
I have SHIFT + Mousewheel up/down bound to Camera Zoom In/Out. Could that was is interfering with it? I didn't think the modifier would have to be unique to the macro.

I also checked to see if focus/self cast was bound in interface and they were not.
If you are binding this to mousewheel, then whenever you press shift+mousewheel, your keybinding takes priority over your macro. If you want macro to work, you gotta unbind shift+mousewheel first.
My healing macro isn't bound to the mousewheel. It is bound to a key. Every other function of the macro works except for the @focus modifier.

Shift is bound to button on the side of my mouse.

I have tried swapping the modifier with Ctrl and Alt(I have neither bound currently) but neither of them can make the macro function using the @focus aspect.

This is my first attempt at using a focus macro so not even sure if the context is correct.

I just unbound Shift from camera in/out and still the macro does not work. Currently Shift is not being used by another other non default feature.
/cast [mod:shift,@focus,help,nodead][@mouseover,help,nodead][help,nodead][@player] Riptide

Make sure that shift is not set to SELF or FOCUS cast modifier in the combat settings. Make sure that SHIFT+macro's key is not used by a default function such as action bar paging.
Copied & Pasted. Made sure that neither Focus or Self cast was checked(they weren't) And Shift + Macro isn't being used by anything else.

Still behaving like I posted. Works fine except for the focus part. I guess Focus Healing and me just don't mix.

Thanks for all the help guys I really appreciate it.
Hmm. And shift+whatever key you're binding this to isn't already bound to something in default keybindings?
Can you hold down the button you've remapped to shift and run this with it held?/dump IsShiftKeyDown(), SecureCmdOptionParse("[mod:shift]")

What does it output?
Empty Result?
07/31/2012 03:33 PMPosted by Sedivy
Hmm. And shift+whatever key you're binding this to isn't already bound to something in default keybindings?

Not that I can find. Have it 4 key(other heals being bound to other number keys).

Maybe I have a busted shifter lol.
07/31/2012 03:45 PMPosted by Jhureki
Empty Result?

What happens when you hold the actual shift key down when you run that?
If the command I posted outputs "empty result" when used with the button mapped to the shift key held down, it would seem that WoW doesn't recognise it as shift.

Join the Conversation

Return to Forum