[Bug] Cannot Complete Gather the Intelligence

Bug Report
I can not loot the item Twilight Communique to finish the Gather the Intelligence quest in Mount Hyjal. It has the looting castbar, but the item never actually gets looted. I know its not just me, because two other players have tried to loot the item and couldn't. The other part of the quest, the Hyjal Battleplans can be looted.

This is currently happening on Darkspear. I've tried dropping the quest and picking it back up. It didn't work. Any suggestions?
This Is happening to me too. I tried the same thing as you. It worked for me on my other character just last week.
I have talked to a GM 3 times about this quest. They blew it off the first couple times, saying it was probably my add-ons messing it up, or to reload my UI, but in the end they acknowledged it as a bug and then blew me off again. I guess we will just have to finish this whenever they finally get around to it.
Just as an update: I can now loot the item. :)
So whats best? just wait it out for the looting?
I ran into it yesterday. I tried several times, including without any addons. That didn't help. It was this character.

Clicking on the Crate of Scrolls generates a "stealing" cast bar, but the loot window that opens is empty. Another symptom is that the Twilight Guard completely ignores you if you try to steal the Twilight Communique directly in front of him. As the OP mentioned, the Hyjal Battleplans (the other objective) are not affected.

There is also a couple of comments about this over on Wowhead. (http://www.wowhead.com/quest=25296#comments:id=1703609)
Yup, i'm running into this bug also! Blizz please help!
There are 3 of us trying to do this today and same thing-shows toon stealing but doesn't register and no item looted.
Same here. Got the plans just fine, won't let me pick up the communique. Dropped the quest and tried again. I watched a horde toon try also. He gave up as well.

Edit: Just tried logging out and back in. No go either..:/
Seeing this issue today as well. Tried re-logging, dropping the quest, etc. Able to pick up the Hyjal Battleplans just fine, but the Communique just gives me an empty loot window.

There are multiple other players hovering around this as well that appear to be having the same issue.
08/07/2012 05:03 PMPosted by Morlanda
Just as an update: I can now loot the item. :)

Just curious, did you do anything or did you just come back and try it?
seriously this has been going on for a few months now and hasnt been fixed, just ran into this today, so LAME, its like the bug on my mage where i have to listen to the casting NON STOP which has been a blue posted known bug for couple months now too. blizzard please fix these KNOWN issues.
this is the same for me, let me know when this crap gets fixed!
Same here! :( It's annoying. D:
Been trying this on my lock today with the same trouble. Most of the gather quests in Hyjal were giving my trouble actually. I tried it at 9AM and there was a questbot pally stuck on it, try to loot it, take two steps back, try to loot it, ect, ect, ect... got back on at 10PM, 13 hours later, to try it again that same pally is still there lol... maybe they are doing this on purpose as a bot trap. It can't honestly be that difficult to fix or they would have by now.
I too have a blank loot box. I click the item, the stealing bar appears, then when the box for loot opens, there's nothing in it. There's at least 2 others in the game waiting as well. I also tried "stealing" when the guard was standing right in front of me multiple times, and the guard does nothing.
Issue is happening as well. Just started to grind out last few levels on my Druid, and stuck on this stupid box. It seems like the NPC watching is murdered and takes forever to spawn, during which the other faction (horde in this case), bug the box so that no one else can loot.

This is super lame, and is not the first quest that is being blocked out by the opposing faction. This needs to be fixed !!
Having the same issue with this quest. I was able to collect the "Hyjal Battleplans" easily but the "Twilight Communique" are unable to be looted. They are present in the game world, you can click on it and it starts the loot animation but you just get nothing from it.

I have tried to relog a few times, abandoned and reaccepted the quest, flew in and out of the zone, killed the NPC guard a few times, no luck :(

[Frostmourne, US] FWIW
as of right now i can say it is not fixed i am trying to do that quest on duskwood server and i get a blank loot screen
this has been happening to me to

what do we do ?

Join the Conversation

Return to Forum