Alt+Another Modifier Macros Not Working?

UI and Macro
I'm trying to build a focus macro but I'm having a hell of a time doing it. Most of my normal focus macros work flawlessly, however, I'm trying to get my repentance macro to work. This is one of my focus macros that HAS been working:

/cast [target=focus, modifier:shift] Hammer of Justice; Hammer of Justice

The differences in the one that isn't working is that its base keybind uses a modifier to activate it normally, while the one above just requires me to press the right key. HOWEVER what I have noticed is that moving it wont solve the problem. I also tested using two modifiers to activate an ability based on keybinding the action bar as opposed to writing it into the macro, and that worked too. Anyway, here's the borked macro:

/cast [target=focus, modifier:alt] Repentance; Repentance

The hunch I'm getting is that using an alt modifier with another modifier wont work, or just using alt as a modifier in macros in general. I tried testing it using ctrl instead of alt, and shift+ctrl press successfully casts on my focus, as does shift press on my target.

Are alt modifier macros just broken right now, or am I doing something wrong?
A common occurrence is under Interface->Combat->"Focus Cast Key" and "Self Cast Key" that one of these has one of the 3 modifiers bound to it. I would check to see if either of these have alt bound to it. If not, head to your keybindings, find a unbound function, and bind alt+ w/e you have your macro on and see if it tells you anything has become unbound.

Edit: Spelling.
I checked that and had one set to the alt key. I made sure both were at none but that didn't fix out.

Turns out it was your second suggestion, as that setting was for a pet skill keybind on a hidden bar I use on my alts. :P

Thanks a lot. I hate it when macroing gives me issues. >_<
bueno si me entienden me sirvio ese era el macro que estaba buscando toda mi vida jaja gracias =)

Join the Conversation

Return to Forum