Updating OS X

Mac Technical Support
Hi there.
I have recently discovered that upon the MoP pre-patch, you will no longer be able to launch the game from Mac OS X 10.5.x. I am currently running 10.5.8, and was just wondering how to go about updating my OS to 10.6 to continue playing the game, as I have no idea where to start.
Thanks!
Perfect. Thank you very, very much S4d1k. :)
Not so perfect, the min sys requirements according to Blizz is 10.7.4 and up.

AND there were significant changes in 10.7 that made a lot of users not upgrade because their workflow depending on software that was knocked out of the box by deletion of some essential OS services.

OTOH, AP subscribers will have a perfect reason to drop there sub.
Not so perfect, the min sys requirements according to Blizz is 10.7.4 and up.

AND there were significant changes in 10.7 that made a lot of users not upgrade because their workflow depending on software that was knocked out of the box by deletion of some essential OS services.

OTOH, AP subscribers will have a perfect reason to drop there sub.
The launcher states, exactly, (i copied and pasted)
World of Warcraft requires Mac OS X version 10.6 or later
So I think 10.6 will be okay throughout Mists.
10.6.8 will work just fine for MoP.
08/12/2012 12:12 AMPosted by Elurain
10.6.8 will work just fine for MoP.

Yes, but remember, we suggest upgrading to one of the 2 newer operating systems for Mac. This helps provide optimal gameplay experience since you will have newer drivers and updates.

Join the Conversation

Return to Forum