Patch 5.0.4 for Linux users

Technical Support
1 2 3 5 Next
Hi Blizzard,

Yes we know you don't officially support Linux - but there are many thousands of us using it, via WINE to enjoy WoW.

As with most patches, Linux users struggle to sometimes get the background downloading to run correctly, or to obtain patches via the normal Launcher.

Since I'm sure you are trying to anticipate patch 5.0.4 issues, I/we would appreciate some initial guidance for problems downloading the new patch - or at least a may to manually download the patch via FTP etc and upgrade WoW manually.

It's a trauma us Linux users are used to, but we still pay a monthly fee - and would really like to carry on paying, assuming we can get 5.0.4 going.

As it stands now, I cant get the background downloader to see anything new, its last download was the 14.9GB 4.3.4.1555 patch

Thanks

DC
Do you have a directory called "tempmig" in your wow directory? If not best thing i can think of is to copy the 6 gigs of data from a friends machine and just put the directory on your machine patch day it will see the files and patch it.
Been running Linux, for wow, since patch 2.3 destroyed my sound in vista years ago.

Best Decision EVER!

I've not even logged into vista for a couple years now, learning how to do everything as well or better under LINUX (even streaming video files from a media center like thing (Ushare) to my xbox 360)

I've really never had issues patching wow up; In fact, I often come here to the tech forums to bask in the irony that many windows users have more trouble than I do (since I generally have none at all.)

My only recent problem patching was due to running the wow 64 bit exe, without knowing there was a patch. But again, windows users have the same problem.

------------

Don't worry about thinking that the downloader is doing nothing; Other threads by windows users say the same thing. As previous said, that temp whatever file is all there is now (not sure if that is totally mop, since its still betaing and may not be the final pre expansion thing.)
I just ran launcher.exe, under wine, instead of the 64 bit exe that I play with.

Its background downloading whatever exists now fine, at up to 511 Kbytes a second.
The other half of the patch has not been released yet far as I know. The temp folder is part of a actual patch. Your wow sounds like it's at the place you should be at this moment.

Make sure you are using wine 1.4. And latest open gl, 4.2.... 4.3 which was released august 2012 is equivalent to directx 11. Has all the shadowing and stuff, Ati and nvidia will most likely be releasing this new open gl in september. I believe the ati 5xxx and up will support 4.3. Nvidia 5xx and up will support 4.3. But to be sure, I would double check that.
08/25/2012 03:58 PMPosted by Druenny
The other half of the patch has not been released yet far as I know


Haven't seen anything no.

There is stuff missing from them tho.

For example the prepatch files appear to be missing the client files for both 32 bit and 64 bit. I had a look using Ladik's MPQ editor today. No programs in those MPQ files at all.
From another thread:

Going to the patch mirror helped - I now have the TempMig folder with data in it:
http://patchup.info/wow/tfil/na/

Blizz downloader still keeps crashing though with write exceptions.

I run wow under linux on a laptop and main PC, both used to update smoothly, but recently, every patch has been a struggle - mainly due to the downloader dying constantly.
Linux users: Using WINE

I'm currently stuck on Launcher downloading updated tools 1/3rd way

Any ideas?

DC
Granted I use PlayOnLinux I got past the launcher error and what not by changing the wine version to 1.5.11

the optimization is taking it's sweet time but after looking at the forums a lot of other people are having the same thing happen.

As I get things going I will update.
Currently using WINE 1.2.2

ran repair - then launcher - it seemed to go through the downloading updated tools (full blue bar) - then launcher restarted and is back at Downloading updated tools 1/3rd again

DC
There is a WOW folder re-configure .. that has many changes to the client side code .. IF you have problems as of patch day perhaps you havent got the new version of the main folder. The new version also installs the 5.0.4 pre-d/l patch and fails to tell the new launcher you have it .. so the old skip out once at the 3 stage patch loading screen rerun launcher ( if error run appropriate repair ) rerun launcher and wait for realm to come online works.
Update:

Everything optimizes and installs (Though the optimization takes forever)

Then close out your launcher. For those like me who use opengl for graphics this optimization turns you back to direct x 9 or so. Go to your config.wtf and change

SET gxAPI "D3D9"

to

SET gxAPI "OpenGL"

then start her up so far so good.
Hey Morighann,

Got to the Updating setup files - and getting crash errors constantly

====
Agent: (build 1040)

Exe: C:\users\Public\Application Data\Battle.net\Agent\Agent.1040\Agent.exe
Time: Aug 28, 2012 11:02:26.369 PM
User: darkclaw
Computer: darkclaw-deskto
------------------------------------------------------------------------------

This application has encountered a critical error:

ERROR #1 (0x13370001) Fatal Exception
Program: C:\users\Public\Application Data\Battle.net\Agent\Agent.1040\Agent.exe
Exception: 0x80000100 (unknown exception) at 0073:7BC4B720

** DId you get this? Any ideas?

DC
Darkclawwuff, I'm having the exact same problem.. I get the same error, I'm currently looking for a solution.. Surely, we can't be the only 2 ppl having this error. Will repost if I can figure it out. Help from anybody would be appreciated...
I found this site..

http://www.mmo-champion.com/threads/1186437-Patch-5-0-4-Linux-Guide-%28or-Problems-You-and-how-to-fix-them-%29

HOWEVER, I'm still having trouble as well..

The launcher starts, says [DOWNLOADING UPDATED TOOLS...] and the progress bar stops at 1/3 of the way, and I just stop there..

Will continue tinkering and keep you posted on my progress
As for the AGENT issue.. Run that from the TERMINAL and it should go thru the process... Then After that runs, I'm stuck on Above issue.. :_(
Im trying to update to WINE 1.5.11 now.. I'll see if that makes any difference..
I am also having the exact same problem. it crashes with some reference to agent.exe after 1/3 of the progress bar. I have also tried running the backgrounddownloader.exe and it comes up with an error after a couple of second saying this download is not authorized. Ill be searching for solutions myself and let you guys know if i find any fixes.
Yes Sir. Mission Accomplished.

STEP 1. Run agent in terminal

STEP 2. Update to WINE 1.5.11

STEP 3. in terminal type [ pkill wine ] to kill the old wine process

STEP 4. wine -opengl Wow.exe (AKA PLAY BALL!)
In case you have issues updating wine to 1.5.11, go here and follow the instructions at the top.

http://www.mmo-champion.com/threads/1186437-Patch-5-0-4-Linux-Guide-%28or-Problems-You-and-how-to-fix-them-%29

Join the Conversation

Return to Forum