Guild chat error "Under Construction"?

Mobile Bug Report
Hi there, I recently purchased a Vodafone smart 858 running android 2.2, and downloaded the now free armoury. All features work fine except the guild chat, when I click to sign in it thinks for a few seconds then says "Guild Chat Error" "This feature is currently under construction. Thank you for your patience!"

I just want to know is it really under construction? If so I will be patient.. or is this an error caused by somethng else? (maybe the push service?)

Thanks for your time.
I have been getting the same error. I wonder what is happening?
Happening to me as well. Using a AT&T iPhone 4.
I have this same problem with my Samsung Galaxy phone. Tried both Thrall and Stormrage servers, get the same error each time, this feature is under construction.

It was working fine prior to the tuesday patch.
I am hoping that once they release the new version it will be a universal version that will also work on the iPad...
Nothing yet and its been 2 days. I cant even find a statement of acknowledgement from blizz, I guess that since its now free they dont need to rush :P
Same here, except that it also wasn't working in my main's guild after the switch to free service and before the patch (just didn't have the error message). Now it also doesn't work for the other guild.
:( -=*=- BuMp! -=*=-
i am using the app on the sony ericsson xperia play and getting the same error
Im getting the same issue. Under construction
I remember someone asking for realid integration and blizz responded with "we would like for this to happen in the near future". I am hoping this is the near future and it's what they are doing.
08/28/2012 10:53 PMPosted by Wilebosk

Any idea how long it will be down for? (:

I'm not entirely certain, but my best estimate would be by the end of the work week. If not, sometime next week.

It'll be back at the end of this week or next week.
I feel better now knowing I am not alone.. :D What version of android are you people using?
Log out, and then log back in on the app. Works for me.
Also make sure the app is updated. That actually fixed it for me.
Guild Chat is up and running once again.

As quoted from a previous post, there were stability issues when we initially opened Guild Chat up to the general public and it completely failed when we updated WoW to 5.0.4. This should now be resolved.

There may be some individual problems with some realms, but that's an ongoing issue that's out of the mobile team's hands. (Although I am helping drive the efforts to remove this roadblock.)

If you encounter any particular bugs with Guild Chat, let me know and I'll check it out.
The "Under Construction" message is gone. Instead my toons on Stormrage encounter the "Connection timed out" message and cannot log in. My character on Mal'ganis can log in. This is how it was before the patch, but after the move to free service.

Edit 9/1/2012: Fixed! Thank you Blizzard.
I'm on stormrage as well and since the patch I have not been able to log on to guild chat once. I've tried everything to get back on without avail. I can log onto other servers but not my main which is stormrage. Please help. I have same timed out message. Never had problems when I paid for it. Lol

Join the Conversation

Return to Forum