Tech Tips for Patch 5.0.4

Technical Support
its simple Blizz got ya cash and they to busy spending it then trying to fix things... its the norm for them.. every time they introduce some thing new they fail
Mine also gets stuck after launcher updates tools . The play button won't work and launcher disappears,very frustrated I've deleted wtf interface and cache still no help . Please anyone got a fix for this one???
"Failed to download required file, please check your internet connection." Please help, I've tried everything the forums suggested.
delete your addons? really? realize this was posted before the patch but with the mess this patch has been i wouldn't bother posting anything else if thats the best you can do.

maybe a little harsh and i'm pretty understanding on patch days but it's now thursday and i'm still still not live on something that shouldn't have taken more than a couple hrs.
Liddon: to update your graphic drivers manually go to desktop or start menu and find: My computer, right click it to view properties. Click the Hardware tab. Click the Device Manager Button.
Find were it says: Display Adapters. open up the menu tree (Click the + and then will be - sign next to Display Adaptions. Right click the Graphics controller that's listed there. Select update Driver from the mouse menu. Hardware Update Wizard will pop up. Select "Yes this time only" then "next" button. Select Install the hardware automatically. Click next. It will search for the update. This will take a few mins. (As in make a pot of coffee "few min" XD) If it finds anything it'll put it in for you and or you click "accept" "ok" or "finish" forget witch as updates don't come along to often.. If finds nothing just click Finish. Good rule of thumb to update everything in your Device Manger once a month. Take the time to update them all and see if you find any that are are not updated. Good luck!

(and yep I get that same error you get once in a while, that's windows f-d up way to reminding us HEY Graphics driver needs and update! *mutters* Don't put off updating your graphics drivers because when I do after about 3 days of getting everything all whacked out like you described (desktop icons huge programs huge extra) I'll get a blue screen of death error that makes it god damn hard to get into windows to fix it! ( /wrist XD )
Ih and am having this problem: stuck on "reconfiguring game files please wait" 0% Yippee!! I'm so frekn bored. Time to dig into my book storage totes...
can't download the game.
Im wondering is the game menu where it shows if the patch has downloaded keeps reading 0% is waiting for the expansion next month. I would just love to get my framerate up so I can really play. Anyone else having this problem
Thank you for the tips guys.

I uninstalled/re-installed WoW, and apparently my drivers are currently as up to date as they can get, but I am still having the same issue. Now what?

Wait... I lied. My computer failed to detect the updated driver software, which I found and downloaded directly from AMD's website. Just finished installing it, and problem fixed. Thanks again!
This is just weird enough to think it might be of interest here to someone. My nVidia GTX-295 doesn't support DirectX 11, but that's exactly what my WoW system video settings show I'm running since the patch. All my other settings were left alone, a mix of high and ultra, best I can tell. My actual visuals are gorgeous, and I'm seening up to 200fps, but almost always above 100fps, even under load. Sheesh, go figgerl!

edit: k it looks like WoW sees Windows 7 and puts Directx 11 in the window, but the card continues to run 10, as designed. got that off a nerd forum.
Hello, I'd like to ask something...
I just reinstall WoW and follow the steps for new patch..
The launcher's still downloading now, pass the setup progress (14%)
But I want to ask, should I run the launcher in administrator mode
or can I run in normal mode?
What happens to the people who paid money for MoP and now can't play unless they buy a whole knew computer/laptop????

Or if we can't update our Drivers because it is "a customized computer manufacturer driver" and they cannot update it???
Loniya, if your using "a customized computer manufacturer driver", you can still update your driver. Unless you built your video card yourself every company releases drivers. You wont be able to use your customized driver but those are the breaks.
09/01/2012 11:09 AMPosted by Attema
Loniya, if your using "a customized computer manufacturer driver", you can still update your driver. Unless you built your video card yourself every company releases drivers. You wont be able to use your customized driver but those are the breaks.


Ah yes... I found that out from browsing the 2nd website blizzard sent and I scanned to make sure mine was up to date (it was).

After trying many of the suggested things on these guides to the 5.0.4 updates all failed me. So someone in my guild suggested a change in the Directx11 to Directx9, my suggestion to all who see this post go into the WoW game > Game Menu > System > Advanced > change Directx11 to Directx9.

All I can say is less lag now than I had before the update even happened! :)
Okay i am trying to do the MoP Optimization thing and it wont go past zero. Every few minutes a pop up will say "cannot download a required update. please check you Internet Connection and try again." Plz help blizz :D
Also My internet connection is perfectly fine and ive checked it multiple times
yes , and I'm very frustrated. I 've done all the troubleshooting tips and still can't get into the game. So mad you have no idea. Couldn't get into the beta patch either so since no one is coming up with a solution I'm probably going to have to cancel wow. No use paying for something you can't get into. If anyone has figured out some or sounds like it is on Battlenet side( they come up with a solution ) please let me know soon. I really don't want to cancel but see no other solution??
I came back from vacation to this "update". I've tried to resolve this by deleting WTF, Interface, and Cache files, disabling my firewall and anti virus and I keep getting to the "optimization" step of the download and upon starting said optimization I get "Failed to download a required update. Please check your internet connection and try again." any suggestions?
I dropped to direct X 9 and was disconnected within 2 minutes of logging in like I did under X 11. No good.

Join the Conversation

Return to Forum