Swiftmend bugged

Bug Report
Swiftmend appears to be pretty bugged. Right now it heals my target 25% of the time, 75% of the time it gives me the blue hand cursor to manually click someone (and yes, my target has rejuv on). This often means unnecessary deaths in groups since I use it as an instant "oh !@#$" heal.
This has been happening with my PW:S as well. I think the problem is the button is not displaying a CD or not displaying it correctly.
Swiftmend appears to have changed in the way it queues itself, period, for me. Previously, if I attempted to heal somebody with swiftmend who didn't have a rejuv or regrowth hot on them, I would get an error speech bit ("I can't do that" or something similar), and nothing further would happen. Since the patch, it instead stores the spell in the cursor, giving me the blue cursor hand, which seems to be causing an issue when I cast rejuv and then swiftmend very shortly afterward. I run at a fine latency at any given period of time (typically around 50ms), and while I'm sure I could fiddle with the queue latency settings some to make it a less prevalent issue, the fact that it instigates the blue hand at all is a new frustration for me.

At the very least, is there a means of clearing the blue cursor without casting the spell or hitting esc? WoW occasionally minimizes when I hit esc too quickly (to clear my target and then to clear my spell hand), and when you combine that with the fact that I'm now having trouble getting swiftmend to cast properly (when the target has a prerequisite hot on them, even), I'm suddenly running into a lot of unneccessary deaths. =(
Another issue that I have noticed with swiftmend is that it is not working for regrowth. I double checked the spell to make sure that it still works with swiftmend, and according to the spell it still should. However, swiftmend is only working with rejuv. I have put in a ticket for this and still no response. Sadly Swiftmend in general seems to be having a lot of issues. I have read several forums on the issues that swiftmend is experiencing. Hopefully, Blizz will fix the issue soon.
@Neysa: I am not able to test it at the moment, but I noticed you are using the glyph of regrowth, which removes the hot portion of the spell. That could be why your swiftmend is not working with it.

As for the swiftmend bug in general, I do hope it gets fixed soon, it is quite frustrating.
For real. Yeah my druid is like my 4th in line alt who I barely care about - when I hop on him, it is rough.

Is this working as intended to make people frustrated with druids and reroll monks for their leather healing needs? or is this a bug?

I only use it for upcoming group heal moments when i know i have enough time to push escape or do another cast to break that stupid invalid target crap. I used to use it as a swift mend.... imagine that.
I would like to get some feedback about this issue, one way or another. Is the new storing of swiftmend working as intended, or an issue that's going to be addressed?

As a separate note, I isolated the issue of my client minimizing. In order to use my mouse's extra keys in WoW, I have to change them to represent keybinds (ctrl+4, etc.). So when attempting to hit escape quickly so I can try to use swiftmend again, ctrl+esc brings up my start menu, minimizing the game. I ended up downloading a program, AutoHotKey, to disable the ctrl+esc keybind in Windows, and as long as I run the script as an administrator, I have no issues with that anymore. So at least I can waste time hitting esc repeatedly, trying to get swiftmend to go off properly without risking my game minimizing. The same would go for anybody who uses the alt key as a modifier to cast their spells; alt+esc shows the Windows desktop, so if you're hitting alt too closely to spamming esc in order to clear the swiftmend stuck in your cursor, you'll risk minimizing your game as well.

It would really be much easier to just have the spell fail from the get go if the prerequisites aren't met. I've tried to slow down my casting, but if I hit swiftmend a split second before my global cooldown resets, and even a split second or so -after- my global cooldown resets, the spell gets stored. Cue esc mashing. =(
OH GOD I hope they see this. Its been bothering me since Panda hit. It DEFINITELY effects my abilities as a healer. It might just be a couple seconds, but the second it takes me to actually hover and click over a target because its not automatically registering, can cost a life make a wipe. v_v
I often have my cursor queued over my next action while I am working the keyboard to chain things as quickly as possible. This blue cursor makes this a problem for swiftmend, but it would be nice to be able to disable this mechanic for all spells.

Join the Conversation

Return to Forum