Softbank - Login Failed Too many attempts

Mobile Bug Report
Prev 1 5 6 7 Next
"Login Failed Unable to establish connection to server"

Sharp 106sh Android 4.0 and my PC NTT hikari flets Sofbank Yahoo

Both provides Softbank
I am also living in Japan, but up north in Hokkaido. I got the Armory App a number of months ago on my iPhone 5 and had no issues using it until 2 weeks ago. Now, I can only use it at home on my WiFi network.

If I try to use it anywhere else, (regardless of connection type: 3G/4G/LTE/WiFi) I get the same error as everyone else:
Login Failed Unable to establish connection to server

As Wilebosk has mentioned before, this is an IP issue, and one I've faced when trying to log into WoW on my laptop from anywhere else other than my home. It seems that Blizzard's servers have recognized only my home IP address as a valid connection and everywhere else in Japan is considered a "bad" IP.

If I try to connect from work, or a hotel, or a friends apt, then I either have to change my password as the servers think I'm trying to break into my own account (even though I log in with the correct information) or I'm blocked out-right. Both are very annoying and for the past 8 years I've been in Japan neither has been resolved.

This is probably exactly the same thing that's happening with the Armory App. Unfortunately for us here in Japan, (like my PC logging issues) I doubt this will ever be resolved.
I would also like to throw my hat in with the "Too many attempts" crowd, however rather than being with Softbank, my Galaxy S III running Android is with Docomo, so I doubt it is Softbank specific.
Just got this app a week ago and thought it was just me. Glad it isn't. iPhone 4S 6.1.2 on SoftBank. Get login failed too many attempts whether I am on wifi or 3G it doesn't matter. Knew thigs weren't going to be fun when I first tried to login and got that error. In Kanagawa, south of Yokohama, if location is needed. Reminds me of the issues last year just trying to login to my account at all.

If more information is needed, let me know. Will try to remember to keep tabs on this thread. (If Captcha just to read forums doesn't drive me insane first... Arrrrgggggh!)
I just downloaded the Armory app for iPhone, and I'm getting the "Login Failed, Too Many Attempts" error whenever I try to log in. :( Kantou region of Japan, iPhone 4, Softbank, same error on both 3G and wifi.

For some reason, Softbank isn't playing nice with Blizzard lately. I've been in contact with Blizzard in the last few weeks about being unable to access any of the websites on a Softbank connection. Both my home wifi and my iPhone were blocked (both Softbank), but my friend who uses AU was able to connect just fine. I was able to access the site again as of a few days ago (though I have to go through the capcha entry each time). At this point I'm just happy to be able to look at the forums without using a VPN, but I really hope we can sort out what's causing the problems between Softbank and Blizz.

Has anyone here tried contacting Softbank directly about the problem? In my ticket reply, Blizz said that my trace route showed the problem was probably on Softbank's side. I asked about it at a local Softbank shop (in my not-very-good Japanese), but neither the lady I asked nor the person she called for a consult seemed to really understand the problem. If anyone here can speak decent technical Japanese, I'd be curious what Softbank's tech support has to say.
03/18/2013 10:50 AMPosted by Jaena
I just downloaded the Armory app for iPhone, and I'm getting the "Login Failed, Too Many Attempts" error whenever I try to log in. :( Kantou region of Japan, iPhone 4, Softbank, same error on both 3G and wifi.


Which would say to me we're all experiencing IP issues. It's been stated in this thread, and I'm inclined to agree. Especially since it's not confined to just Kanto region or any specific prefecture. Not sure how or why some IPs are being affected, but does make it interesting.

For some reason, Softbank isn't playing nice with Blizzard lately. I've been in contact with Blizzard in the last few weeks about being unable to access any of the websites on a Softbank connection. Both my home wifi and my iPhone were blocked (both Softbank), but my friend who uses AU was able to connect just fine. I was able to access the site again as of a few days ago (though I have to go through the capcha entry each time). At this point I'm just happy to be able to look at the forums without using a VPN, but I really hope we can sort out what's causing the problems between Softbank and Blizz.


It's more than Softbank. Middle of last year, for several months, my husband and I were completely unable to access our accounts at all. And this is through mobile, at home, or anywhere here really. I know we weren't only one, but seems at some point they had a major IP issue then too for Japan. We called several times and got "it's a known issue no eta." Sadly, VPNing into our account got it locked, but were able to straighten that out. Glad to hear you didn't. From the start of this thread, was around time account logging in anywhere here was an issue. So I'm thinking it's a continuation of last years IP issues in Japan. Just seems Mobile Armory is an ongoing on.

Has anyone here tried contacting Softbank directly about the problem? In my ticket reply, Blizz said that my trace route showed the problem was probably on Softbank's side. I asked about it at a local Softbank shop (in my not-very-good Japanese), but neither the lady I asked nor the person she called for a consult seemed to really understand the problem. If anyone here can speak decent technical Japanese, I'd be curious what Softbank's tech support has to say.


Haven't contacted them directly, mainly for fact it's just armory I can't log into. Last post I made here was from my phone, so didn't see it a big deal to call them just for app. But I'm not sure they could be much help. To be honest, we all know Japanese customer support is some of the worst, if you've had to deal with them anyway. :/

Have you tried calling Softbank's English line? Our horrible Japanese can only get so far. But I know if you call the English line they'll act as a translator between you and the person you are trying to talk to. Has helped us quite a few times.
Any update on this issue? I know it's going to take some time, but want to make sure it's not getting swept under the rug as I really would like to use this app :D
Just gonna toss my hat in here to.

Softbank, iPhone 4, up in West Tohoku. Mobile app is too many logins, and logging into battle.net from my phone will generate a "Suspicious activity lockout" repeatedly.

At this point, I downloaded the app about 2-3 weeks ago, and I have never been able to log in with it.
Any update on this issue? I know it's going to take some time, but want to make sure it's not getting swept under the rug as I really would like to use this app :D


I don't even own a rug to sweep stuff under, but I assure you that I collect data from this thread each time it's updated. I don't always have a moment to leave a reply but I do my best.

No updates for now. Investigation is ongoing.
This does not just affect SoftBank users here in Japan. I use NTT DoCoMo with a Galaxy S3 Android. It doesn't matter whether I'm at home on the WiFi (NTT OCN) or at work, I get the same response when I try to log in - Log in Failed Too Many Attempts.

I've uninstalled and re-installed two or three times, but it doesn't help. This app use to work fine until a month or so ago when someone decided it needed an upgrade. Since then I receive the error message every time I try to log in.
This does not just affect SoftBank users here in Japan. I use NTT DoCoMo with a Galaxy S3 Android. It doesn't matter whether I'm at home on the WiFi (NTT OCN) or at work, I get the same response when I try to log in - Log in Failed Too Many Attempts.

I've uninstalled and re-installed two or three times, but it doesn't help. This app use to work fine until a month or so ago when someone decided it needed an upgrade. Since then I receive the error message every time I try to log in.


I've added your report to our investigation.
I used to get the "too many attempts" error, but recently when I try to connect through 3G, it's changed to the "unable to establish connection" error.

This is on an iPhone 4 through Softbank - West Tokyo area.
hello all.. when will the bug too many attempts reset or fix? i really like and need to use this mobile wow armory on my android
USMC stationed in Mainland Japan, using softbank iPhone on a 4G system. app says "to many attempts" and it was my first attempt ever using this app with this device.
I cannot use the appli on WiFi (NTT OCN) with iPod touch. But I can connect it when I used a WiFi router(Aterm MR01LN) for 3G/LTE of NTT DOCOMO.
I haven't seen any new activity on this thread in several months. Is there anyone still experiencing connection problems using Softbank?
I'm still unable to use the mobile armory.

SoftBank, Japan, iPhone 5, iOS 7.0.2
Edit: it doesn't matter if I'm connected to wifi, 4G, or 3G. Still no luck.
I am also having this issue, and I tried it a few times. The issue is no different as the many others, Too Many Login Attempts. Today I was going to download again and see what happens, but decided to check the forums to see if there were others that had this issue. Maybe even a fix which I guess there is not, but being looked at as we speak. (Hopefully still at least)

I as well am using the Softbank service with iPhone 4s updated to the iOS 7.0.2. This is on the 3G network. I cannot answer for wifi since it is inoperable on my iPhone (The wifi decide to completely stop working on my iPhone for some reason).

I am trying to see how this is an IP issue. I find it a bit confusing to understand since I can use the iOS Safari browser to login just fine, with authentication as well, but cannot login using the Armory App. Just seems odd to me. Even more so since seeing this thread has been opened over a year now. I assure you I am not implying doubt on the issue, but just find it quite odd. The world of computers, electronics, and technology always pose issues that never make sense from time to time.

I do hope that it will be resolved someday. The app is quite useful, and I really would love to use it again.
Still no fix? Help us out, blizzard.

Join the Conversation

Return to Forum