failed to download a required install file

Technical Support
It keeps saying i failed to donwload a file, to check my internet connection , i have done this ive run it as administrator and everything, My internet is fine ive checked and checked it and it still says this,

The file it says i didnt download is
Http://distribution.blizzard.com.edgesuite.net/wow-pod/installdata.master.2/win_wow_enus_disk_unencrypted_win.blob

I get thsi everytime ive tried it 15 times already please help me
bump, happening to me as well, even uninstalled/reinstalled can't even get past 4.0.0 and repair is broken too
bump, same here...
Same problem. I have tried all the Tech Support suggestions.
sad thing is gf on same internet connection got hers all downloaded so isn't my net, she is fine but i cant no matter what i do get it to work,
ps i can get my repair to work but i can't get past this error message, I get past update tools i get past update setup files brings wow up with this error message every time.
Found a fix for me at least do this

Selective Startup
Press Windows Key + R
Type msconfig
Click OK
In the General tab:
Choose Selective Startup
Disable (uncheck) Load startup items
Go to the Services tab
Check Hide all Microsoft Services
Click Disable all
Click OK
Click Restart
ps hope this helps
Found a solution for me hope it works for you. delete everything except backgrounddownloder blizzard updater launcher repair and Wow.exe they are other files that say the same but only keep the ones that have a pic icon. And open Wow.exe when your done not the launcher.
yea mine is doing the same thing ive tried about 20 + times and same i used my repair tool and it said that it was sucsessful but i tried again after and same thing failed to download

Join the Conversation

Return to Forum