WoW launcher not working.

Mac Technical Support
Hello.

I've tried opening World of Warcraft and all it does it opens the launcher on my dock for about two seconds before disappearing. I've tried to delete the WoW.mfil file but it won't let me.

If someone has the time, please help me out. :)
How do you mean it won't let you ?

Are you doing the install on an admin user ?

Have you tried restarting ?
everytime i try to open my launcher it just says checking for updates nd then says theres an error nd then closes any idea how to fix it?
internal error occured
Everytime i tried launch my Blizzard launcher. It shows "An Internal error occured and it doesn't download the remaining game data. Please help!
^same thing i open launcher, it closes a window open says internal error occurred etc etc restart contact if this persists. iv done everything possible the patch just wont download.. I've upgraded my mac also to see if it helped but nope.
Mine opens but doesn't initialize. I opened the launcher to get the new patch while I was at uni and when I came home after like 4 hours it was still initializing. Anyone else with this problem?
If you're having the internal error, please try this: http://us.battle.net/wow/en/forum/topic/6489929151#2

@Rollwithdave- This has been reported at universities, as they have additional security settings that can cause issues with patching. Are you able to try this at home or another location?
My launcher is not running the game, it opens, initializes and says game up to date..When i click play the launcher goes away and then reloads the launcher all over again, it just continually does this over and over....HELP!
If you look at your WoW folder in Finder, what versions are the World of Warcraft.app and World of Warcraft Launcher.app at?
Launcher is file version 1.0.0.1113, Wow.app is file version 5.0.4.16016
I just realized this was the MAC Tech Support forum...lol i just googled launcher not working, didnt even pay attention this was a MAC forum....smh....shall i find a windows forum?
I play on a mac and have checked everything mentioned in the forums and still cannot log onto any servers, they still come as being red and disconnect me if i try to log on. This is a new problem that just started this morning. I'm really not sure what to do now
09/11/2012 02:40 PMPosted by Mackena
I play on a mac and have checked everything mentioned in the forums and still cannot log onto any servers, they still come as being red and disconnect me if i try to log on. This is a new problem that just started this morning. I'm really not sure what to do now

What happens when you run the launcher? There was a patch today, so if your client has not patched, then this is why you get this error.
It says an internal error occurred, restart, if problems persist contact customer support
Can you try this and see if it helps?

http://us.battle.net/wow/en/forum/topic/6489929151#2
I just said earlier that I've already tried everything suggested in the forums...
Then something is still borked.

  • How are you launching WoW? (Desktop Shortcut, Dock Icon, via Finder from Application folder, etc)
  • Can you verify that your WoW folder has all these files? http://i50.tinypic.com/2isuxch.png
  • I havent played Wow in some months and a friend convinced me to come back for MoP. I started up my launcher, hoping it would upgrade to the latest patch and start D/L MoP. I open my Wow Launcher (I dont seem to have a -64 version as shown above?) The launcher opens another screen saying World of Warcraft Optimisation. This says it will take 15-60 minutes, I enter my correct admin password, but it does not go any further.

    My launcher is V4.3.4.15595, so not sure if it needs to upgrade patch first? It doesnt give me an option, just goes straight into the Optimisation screen?

    Thanks.
    I have tried all of the previous things before too and the only file im missing is the World of Warcraft original file i have the launcher and the 64 bit client.

    Join the Conversation

    Return to Forum