Failed to read a required file...

Technical Support
Prev 1 2 3 16 Next
Hey guys, I'm not a blue, but I was having this similar problem and was experimenting to look for solutions.

I am running Win7 64-bit.

I went into Program Files (x86) > World of Wacraft > WoW-64.exe

I noticed on twitter today that Blizzard kept re-iterating that a 64-Bit executable was included with the 5.0 patch, so this might be the file they are talking about. It's currently loading something for me, so try it out!

~Edit: typo
seems they are activly avoiding any topics on this issue....
Still looking for help with this... Ive tried everything that has been suggested. Need a blue to help us out.

Alot of people are having this issue.
up up up

wheres the blue post
According to Blizzard on Twitter they are extending the maintenance again, maybe this will correct the issue
same thing here, is there light at the end of the tunnel, or a big door with "ignored" written on it?
i know you guys don't want to hear this, but i reinstalled and it works; only downside is i'm now very slowly downloading 20gb
Hey guys, I was having the same problem myself. I just took the Data, Errors, Logs, Updates, and Temp folders out of my wow folder and threw em on my desktop. It is now downloading as intended. I remembered, I had to do it for another recent patch. Give it a shot let me know if it worked for you as well.
I swear to god every major patch blizzard releases i end up having to reinstall the game... Which should not be necessary
LOL I'm downloading it now on my computer (Barely started) I'm at 7%...and my WoW file is in a 64 bit program file....if this is what I have to look forward too....then there is no point to this. Why is it when Blizzard make updates, especially MAJOR ones...something always goes wrong? Don't they test this crap out first before releasing it to the public? I have NEVER played a game before with such patching and downloading problems...WoW seems to always be broken.

Time to strap on my seat belt and wait for this ERROR everyone is getting from their 64-bits.
Clicked the 64 bit version, it loaded some files. Then relaunched the launcher, Seems to be working fine now.
tried that, didn't work, have fun in-game *cry's*
double post ><
still waiting for a fix :(
i get done with downloading updated tools, and the smaller "checking for updates" window appears, then i get the error "failed to open required file".. Blue help us
3 people working to fix this problem on 1 computer.

We have tried the same. followed the blue post on trouble shooting the patch. all with no luck.

Downloading the Setup.exe folder (as in reinstalling wow) gives the error as soon as you bring up the exe. and the launcher closes.

So after i dowloaded all the installation tools that blizzard has you install when you first open up the WoW launcher. I now am at the point where the launcher is "reconfiguring game files" and after it did that for a good 30-40 minutes i get this message.

"Failed to read a required file. Please close all other applications, temporarily disable your anti-virus software, and try again later."

Ok well i disabled all my Antivirus software (Windows Firewall, Norton's, Malewarebytes, etc.) Restarted my computer and tried it again. Still am getting the same message. I don't know what else I can do to fix this issue; anyone have any idea's?
08/28/2012 01:07 PMPosted by Bearzhuzade
They seem to be actively avoiding the difficult questions currently, I suppose it's a form of customer support triage but it is very frustrating.

Very much so. They have responded to the super minor even mundane issues but not a single post on this one that seems to be affecting a very large peice of the player base
I just went ahead and deleted my entire Data folder, to force the launcher to re-download all the game files. At this point in time, I'm at about 66%, and it's downloading fine. I'm hoping that the issue was due to corrupt data files, and that this fixes it. The downside is that it has to fully download the 20GB+ all over again :(
Never mine ..its working on my 64 bit client...I'm not computer savvy AT it just worked after it downloaded....Can't log into the game yet do Blizzard figuring stuff out...until then I hope you guys get figured out :)

Off to play LoL, GOOD LUCK YALL!

Join the Conversation

Return to Forum