"An unexpected error..." at optimization

Mac Technical Support
Still stuck at 0.8% after all of the above tips. Deleted the intaller tome 1 etc...still stuck. Truly frustrating. Running a Mac fully updated...never an issue until this new patch.
Okay so i'm having the same issue as Feleigh....but mines, i honestly have no idea how to fix it. I've uninstalled WoW like 10 times, it made no difference, I even turned off my firewall...but still nothing. I'm wondering if there is something else i should be looking at to fix this problem...someone please help me.
moved whole install back to my hard drive (had been playing off external with no problems), fixed.
08/28/2012 01:18 PMPosted by Feleigh
No, but I did find the problem. Apparently the Launcher icon on my dock kept trying to open an install I had on an external drive >.> Navigating to my applications folder and opening the launcher in the WoW directory there seemed to resolve the issue.

I've been having this issue for MONTHS now and worked! You tha man!
I dont understand what that means I am having this problem and cant fix it
also I have a mac I dont know if that makes a difference
Are you just updating an existing install? Best thing to do is to uninstall and reinstall using the current web installer. This bypasses the migration process altogether.

You can find instructions on uninstallating/reinstalling with the web installer link on our World of Warcraft Uninstall/Reinstall support article.
no I am just trying to download it :(
I'm having the unexpected error also. I get it right after I agree to the license agreement, so it never actually starts downloading. It closes right after I accept the error.

Any ideas? Can't find any Installer Tome 1.MPQ.part files or any temp files..
I had the same problem as the OP; finally fixed it by dragging the World-of-Warcraft-Setup-enUS installer file from my downloads folder onto my desktop - it's now installing.
Not sure if I'm experiencing the exact same problem.

-just upgraded to 10.8.2 (experiencing kernel panics on WoW startup, on chrome startup, and randomly during battleground pvp screen loads)
- deleted everything wow related
- verified/repaired my harddrive
- downloaded america/oceanic client,
- clicked install, cancels at 0% with a "an unexpected error occured, contact blizz or try again later."
- attempted to install 10+ times with the same error code,
- restarted comp, tried again, error.
- restarted comp holding "d" didn't work.
out of ideas.

I missed this link in my searches,

which mentioned that permissions are restricted in the "downloads" folder or even on your harddrive.
After mounting the disk image I move the World-of-Warcraft-Setup-enUS to the applications folder and opened it there.

Installer is now running. that was a fun 2.5 hours.
WOW it's finally working. I had tried to move the downloader to the applications folder previously, but I was just moving the disk image and not the actual WOW icon. When I moved the actual WOW icon into applications, it opened up properly and is now downloading.

Thanks to everyone who has shared their problems/fixes.
Moving that WoW icon from the image to the desktop worked and fixed this issue for me!
Wow, it does work. Moving to either applications or desktop fixes it! Nice! Thanks a lot guys!
Moving the icon to applications fixed me up. Thanks much guys and gals.
This helped me! Thanks
This was very close to what I needed to do except the /Applications/World of Warcraft/ folder was not there. I created the directory, moved the launcher file to that directory from the strange place it was in after download, and ran the launcher from there.

Join the Conversation

Return to Forum