Checking for updates...

Technical Support
I've been dealing with this since this morning when the patch was being applied.

I get stuck at "Checking for updates..." and it lasts for about 2-3 minutes before crashing and saying it failed to run the program "Agent". I open my process manager and I have 3-5 copies of Agent running. I end the processes and start over and the same thing happens.

I have tried uninstalling all Blizzard products (2 copies of WoW, MoP beta, D3, SC2) and restarting many times and still nothing. Any help?
I think I got it figured out. i just found the article to delete your cache. Seems to be working
Thanks a ton for figuring this out, been having this problem myself :')
This was also an issue for me thanks for the thread worked I did need to click the wow updating window then allow access but all good after that:)
I keep getting a message that says I need permission to delete that folder. Can someone help me figure out how to get permission. How do i sign in as administrator. I have to leave to get my wisdom teeth removed so I won't be able to respond till later.

Thanks for the help though in advance
I've been having this issue since the patch. I've done everything. I deleted WoW to try and solve this the first time. Now I'm re-dowloading WoW and it's "Checking For Updates" I've looked everywhere for the folder and it does not exist. I'm completly clueless. Any ideas?
if you go to the 2nd link from the thread he gave you can copy the link for windows 7 (C:\ProgramData\ and put that into the run or search area from the start button and it will pull the folder up and you can right click it then delete it. I am trying that now i deleted it and now i am redownloading it.
ok with me able to delete the folder through win 7 by my previous post it was able to complete the checking update part and is currently installing on my computer
Alright, I got past checking for updates and when I go to install it and it tells me failed to download a required program please check your internet connection and try again. So I check my internet and obviously it's working. I restarted my computer and tried again and it's still doing it.
go to internet explorer- tools- internet options- connection tab- lan settings and make sure all check boxes are unchecked
Did that, none are checked. Still not working.
I deleted the folder but I am still getting checking for updates. what should I do?
It should be working by then. Make sure you cancel the agent.exe in the process tab on your task manager.
Try addind a DLL override for dnsapi.dll in WINE. Worked for me!
Im having this problem for 5.0.5 im at checking updates still, i deleted cache and still wont work, need help desperately
Thank you so much for posting this! It really helped me fix my problem. I was worried I would miss the launch of MoP due to the stupid checkign for updates. I found a work around but I wanted to make sure I was ready to go.
Thank you!!
Followed all of these steps, had this problem since the patch. Launcher worked once... never again. I am going to miss Mop it seems. I have done all of these things so many times my brain is fizzleing out. Is there a way to download Mop not using the launcher? I can play wow by selecting the game inside the wow folder. (wow.exe) Please help.... leaving to get game in an hour.

Join the Conversation

Return to Forum