Weird Lag / Freezing / Not really sure what

Mac Technical Support
Thanks for the reports. I'll start looking into these and see what I can find out.

When you did the update to 10.7.5, did you run software updates, or do a combo update ( Combo updates are always recommended, as sometimes software updates miss files and drivers.
I updated to 10.7.5 this morning and I ran the combo update from the links provided in these forums.
Nothing for me either
Anyone found any answers to this? I've tried just about everything and nothing works, I really want to play pandaria :/ this sort of makes it unplayable.

Still looking into this.

Can we try doing an SMC reset and PRAM reset and see if it helps? In the past, this has seemed to help with cases like this.

Resetting the SMC

Resetting PRAM and NVRAM
    1. Shut down the computer.
    2. Locate the following keys on the keyboard: Command, Option, P, and R. You will need to hold these keys down simultaneously in step 4.
    3. Turn on the computer.
    4. Press and hold the Command-Option-P-R keys. You must press this key combination before the gray screen appears.
    5. Hold the keys down until the computer restarts and you hear the startup sound for the second time.
    6. Release the keys.
I do not know about the others in this thread, but I've already done all of the techniques you have provided and nothing has worked.
I have also completed all steps, reset my SMC and PRAM and NVRAM and nothing seems to work. Thanks for helping Machkhan hopefully we can work together to find a solution.

No issues with this noticed til today.

Basically running on a fresh install of wow, installed mountain lion and haven't ran but maybe 1 dungeon since. full clean os and wow install whenever that came out and only updated to 5.0 and now hot fix/patches to current. no addons and only one account. So while i haven't empted my folders yet, I don't think that is it... mine's hanging for at least 3-4 secs... sometimes more.

Also had to turn graphics down to bare minimium today cause it seemed to be killing fps ? stutter bad when it was running on fair... hoping that might be related.... after i turned it to low, and then played an hour or 2 it started the freeze crap. But like I said i've hardly played since ML came out...


System Software Overview:

System Version: OS X 10.8.2 (12C54)
Kernel Version: Darwin 12.2.0
Time since boot: 12:15


Hardware Overview:

Model Name: MacBook Pro
Model Identifier: MacBookPro5,2
Processor Name: Intel Core 2 Duo
Processor Speed: 2.8 GHz
Number of Processors: 1
Total Number of Cores: 2
L2 Cache: 6 MB
Memory: 8 GB
Bus Speed: 1.07 GHz
Boot ROM Version: MBP52.008E.B05
SMC Version (system): 1.42f4
Sudden Motion Sensor:
State: Enabled


NVIDIA GeForce 9600M GT:

Chipset Model: NVIDIA GeForce 9600M GT
Type: GPU
Bus: PCIe
PCIe Lane Width: x16
VRAM (Total): 512 MB
Vendor: NVIDIA (0x10de)
Device ID: 0x0647
Revision ID: 0x00a1
ROM Revision: 3436
gMux Version: 1.7.10
Color LCD:
Display Type: LCD
Resolution: 1920 x 1200
Pixel Depth: 32-Bit Color (ARGB8888)
Main Display: Yes
Mirror: Off
Online: Yes
Built-In: Yes

NVIDIA GeForce 9400M:

Chipset Model: NVIDIA GeForce 9400M
Type: GPU
Bus: PCI
VRAM (Total): 256 MB
Vendor: NVIDIA (0x10de)
Device ID: 0x0863
Revision ID: 0x00b1
ROM Revision: 3436
gMux Version: 1.7.10


Input Source ID:
Keyboard Layout: ANSI
This is not a new issue... I have found that the Mac performance of the game is severely messed up. The game is choppy, hangs for no reason, and then force quits itself. My CPU is fine. Fans come on, but they always do, and they are below 4000 rpms usually. Its not my computer. MacBook Pro late 2010 10.8.2 with i5 processor. Plenty of everything. Meets or exceeds the system requirements. The game doesn't run well for any of the panderia content, and overall is laggier than I have ever experienced. This is not a single person issue and I have no explanation as to why this is going on. I have tried everything that the GM's have suggested and no results have come from it. I am sorry but glad to see that I am not alone on the issue. I was starting to think it was just me...
I've been having the same issues since I purchased my new Macbook Pro. My old 2010 ran better than my new one which should not be the case. I'm getting the freezing issues as well and as of last night I have to put all my graphics settings on poor to keep the game from completely locking up as soon as I log in. I have also tried all of these suggestions with no luck. What's worse is I am usually playing by someone with an old Windows laptop and their performance is better than my new $1800 machine. >_< I was really excited about the BIOS update from Apple that I installed that said it should fix the issue of it hanging but now I have worse issues. Wonder if I fried my gfx card while playing WoW with all the overheating issues....Hope we get a fix soon!
I've been having similar issues playing tonight as well. I thought maybe it was server lag, but I turned down all my settings to fair, enabled windowed mode, closed all other applications on my computer and nothing. My 2011 i7 mac mini has lasted at most 10 minutes before either freezing and force quitting itself or requiring me to force quit the game.

Over the last 4.5 hours I was able to get in maybe an actual 30 minutes of game play. Quite frustrating as I have been looking forward to playing again.

Edit: I'm also playing a fresh install of the game and have the most recent update of Mac OSX
Ok, at this point I blew all the folders away, did an SMC reset and I am still having the issues.


System Software Overview:

System Version: OS X 10.8.2 (12C54)
Kernel Version: Darwin 12.2.0
Time since boot: 7 days 4:45


Hardware Overview:

Model Name: Mac Pro
Model Identifier: MacPro5,1
Processor Name: 6-Core Intel Xeon
Processor Speed: 2.93 GHz
Number of Processors: 2
Total Number of Cores: 12
L2 Cache (per Core): 256 KB
L3 Cache (per Processor): 12 MB
Memory: 24 GB
Processor Interconnect Speed: 6.4 GT/s
Boot ROM Version: MP51.007F.B03
SMC Version (system): 1.39f11
SMC Version (processor tray): 1.39f11


ATI Radeon HD 5870:

Chipset Model: ATI Radeon HD 5870
Type: GPU
Bus: PCIe
Slot: Slot-1
PCIe Lane Width: x16
VRAM (Total): 1024 MB
Vendor: ATI (0x1002)
Device ID: 0x6898
Revision ID: 0x0000
ROM Revision: 113-C0780C-194
EFI Driver Version: 01.00.436
Resolution: 1920 x 1080 @ 60 Hz
Pixel Depth: 32-Bit Color (ARGB8888)
Display Serial Number: DFF580CD17DL
Main Display: Yes
Mirror: Off
Online: Yes
Rotation: Supported


Input Source ID:
Keyboard Layout: ANSI
We're still looking into this, but we haven't been able to reproduce to be able to investigate it.

Have y'all tried to do a full uninstall and reinstall using the new 5.0 web installer to see if it due to some other file issue that is causing it to be like this?

Instructions, including the new 5.0 installer link, can be found here:

Getting dc'ed and char lag can type in chat find but cannt not do anything else i have talked to my net company many times over this last week and it is not my net.
Can you do a trace to your realm when these issues happen? This will give more information, as those tests do not reveal much.
I did a complete reinstall of the game. When I did I reinstalled on my iMac as well as my Mac Pro. The iMac has been running fine the last two days, I have not been seeing the issue at all. Reinstalling on my Mac Pro did not fix the issue then. So I copied the whole game folder over from my iMac to the Mac Pro. The issue was present. I also copied the Mac Pro version that was acting up over to my Imac and to a macbook pro. Neither showed the lag issues either.

Below is the trace route I ran from my Mac Pro right after one of the Lag/Freezes.

Traceroute has started…

traceroute to (, 64 hops max, 72 byte packets
1 ( 0.401 ms 0.185 ms 0.155 ms
2 ( 14.796 ms 7.703 ms 7.926 ms
3 ( 19.466 ms 11.302 ms 12.832 ms
4 ( 19.258 ms 20.328 ms 24.954 ms
5 ( 31.330 ms 31.773 ms 31.940 ms
6 ( 26.605 ms 26.142 ms 26.674 ms
7 ( 27.617 ms 27.967 ms 59.320 ms
8 ( 27.663 ms 28.429 ms 26.092 ms
9 ( 35.900 ms 32.572 ms 36.191 ms
10 ( 36.501 ms 34.596 ms 35.621 ms
11 ( 138.903 ms 30.450 ms 31.648 ms
12 ( 40.348 ms ( 81.491 ms 37.594 ms
13 ( 35.582 ms 37.405 ms 35.759 ms
Everything looks fine here. If your iMac works fine but not your Mac Pro, then something else might be going on.

Are you running any apps when on your Mac Pro playing? Can you check your repair-on demand.log and see if it is spamming the repair function to repair data during game play?

This is located in /Users/Shared/ Make sure you remove any computer/usernames in the log.
That log does not exist in that location. There is a log from today when I was playing today, it is called. Agent-20121004-091746059.log, AgentDownload-20121004-091746059.log, Agent-20121004-134558543.log, and AgentDownload-20121004-134558543.log.

The sound.log file was updated today, and it looks like the same info is spammed into the log over and over again. Which I find odd. It looks like SI3 keeps having to be restarted.

Join the Conversation

Return to Forum