Weird Lag / Freezing / Not really sure what

Mac Technical Support
OK, I marked my log, and watched it while I was playing.

This is what was logged right when the issue happened in the game.

10/4 14:25:32.889
10/4 14:25:32.889 => Shutting Down SI3
10/4 14:25:32.889 - Shutting Down SE3
10/4 14:25:32.965 - Shutting Down SE3 COMPLETE.
10/4 14:25:32.965 => Shutting Down SI3 COMPLETE.
10/4 14:25:32.965
10/4 14:25:33.166 => SI3 Init
10/4 14:25:33.166 => WoW Version 5.0.5 (16057) Sep 10 2012
10/4 14:25:33.166
10/4 14:25:33.166 => User Settings Report:
10/4 14:25:33.166 - ========= PLAYBACK =========
10/4 14:25:33.166 - Enable All Sound [1]
10/4 14:25:33.166 - Enable SFX [1]
10/4 14:25:33.166 --- Enable Error Speech [1]
10/4 14:25:33.166 --- Enable Emote Sounds [1]
10/4 14:25:33.166 - Enable Music [1]
10/4 14:25:33.166 --- Loop Music [0]
10/4 14:25:33.166 --- Pet Battle Music [1]
10/4 14:25:33.166 - Enable Ambient Sounds [1]
10/4 14:25:33.166 - Sound at Character [1]
10/4 14:25:33.166 - Sound in Background [1]
10/4 14:25:33.166 - Enable Reverb [1]
10/4 14:25:33.166 - Enable Software HRTF [0]
10/4 14:25:33.166 - Sound Quality [2]
10/4 14:25:33.166 -
10/4 14:25:33.166 - ========== VOLUME ==========
10/4 14:25:33.166 - Master Volume [0.20]
10/4 14:25:33.166 - SFX Volume [1.00]
10/4 14:25:33.166 - Music Volume [0.40]
10/4 14:25:33.166 - Ambience Volume [0.40]
10/4 14:25:33.166 -
10/4 14:25:33.166 - =========== MISC ===========
10/4 14:25:33.166 - Sound Channels [64]
10/4 14:25:33.166 - Use Hardware [0]
10/4 14:25:33.166 - Mix Mode 2 [0]
10/4 14:25:33.166 - DSP Buffer Size [AUTO]
10/4 14:25:33.166 - Armor Foley SFX (Self) [1]
10/4 14:25:33.166 - Armor Foley SFX (Others) [1]
10/4 14:25:33.166 => End of User Settings Report
10/4 14:25:33.166
10/4 14:25:33.166 - SE3 Init...
10/4 14:25:33.166 - FMOD Memory Init
10/4 14:25:33.166 - FMOD System Create
10/4 14:25:33.166 - Setting Output Type
10/4 14:25:33.173 - 6 Output drivers detected
10/4 14:25:33.173 --- [0] System Default
10/4 14:25:33.188 --- [1] Built-in Line Output
10/4 14:25:33.201 --- [2] AirPlay
10/4 14:25:33.212 --- [3] Built-in Output
10/4 14:25:33.223 --- [4] Built-in Digital Output
10/4 14:25:33.233 --- [5] LogMeInSoundDriver
10/4 14:25:33.273 ** Using User Specified Driver [1] Built-in Line Output
10/4 14:25:33.292 - DSPBufferSize = AUTO DETECT
10/4 14:25:33.292 - Setting DSP Buffer Size
10/4 14:25:33.292 - Using Control Panel Speaker Mode STEREO
10/4 14:25:33.292 - Setting Software Format (44100, 2, 2).
10/4 14:25:33.292 - Requested 64 channels.
10/4 14:25:33.292 - Initializing Software Channels
10/4 14:25:33.303 - Init FMOD Game System
10/4 14:25:33.303 - Ok
10/4 14:25:33.303 - Setting Rolloff Scale
10/4 14:25:33.303 - Setting Rolloff Callback
10/4 14:25:33.303 - Sound Bus Init
10/4 14:25:33.303 - Init Suppressors
10/4 14:25:33.339 - SE3 Init Success.
10/4 14:25:33.345 - Setting device callback
10/4 14:25:33.345 => SI3 Init Complete.
Yes, I'm seeing it too. Even after the latest patch that was to address some Mac CPU issues. In fact, could have been caused by it? I even downgraded my settings from Ultra and still no difference.

At a fairly regular interval the game will freeze from about 1 second and then resume. At this point the area's music loop will restart.

Now, what really surprised me is that this also happens on the character logon screen.

Really irritating in instances, I can tell you.

I'm getting this exact problem. I've posted about it but not gotten any responses. It seems (at least to me) to be sound related. It happens at very inopportune moments. I'm missing content, particularly in game cinematics as everything freezes for the second or fraction of second, and the sound cuts out and the cinematic jumps to the end. Then everything is ok again.

I seriously regret missing so many of the cut scenes. It hasn't been a show stopper but I would hate to see what it does to raiders and I'm pretty sure its going to get me killed in PvP.
09/26/2012 09:34 AMPosted by Helderque
This is not a new issue... I have found that the Mac performance of the game is severely messed up. The game is choppy, hangs for no reason, and then force quits itself. My CPU is fine. Fans come on, but they always do, and they are below 4000 rpms usually. Its not my computer. MacBook Pro late 2010 10.8.2 with i5 processor. Plenty of everything. Meets or exceeds the system requirements. The game doesn't run well for any of the panderia content, and overall is laggier than I have ever experienced. This is not a single person issue and I have no explanation as to why this is going on. I have tried everything that the GM's have suggested and no results have come from it. I am sorry but glad to see that I am not alone on the issue. I was starting to think it was just me...

I haven't had bad performance in general.
This issue however is highly specific.

I just experienced it for instance. My character is standing still in the Silken Fields. The music is playing. I'm not touching the keyboard or the mouse. Suddenly the screen freezes. Music halts, ambient sound halts, then the music loops back to the beginning. It was about a second. From my perspective, nothing was happening.

I'm running on a fairly high end iMac and for all intents and purposes, WOW normally runs great. Just this sudden glitch. It's intermittent but frequent. I can't explain it but I believe it is sound related, and has something to do with the starting and stopping of ambient sounds.

OS X 10.8.2
Model Name: iMac
Model Identifier: iMac12,2
Processor Name: Intel Core i7
Processor Speed: 3.4 GHz
Number of Processors: 1
Total Number of Cores: 4
L2 Cache (per Core): 256 KB
L3 Cache: 8 MB
Memory: 12 GB
Boot ROM Version: IM121.0047.B1F
SMC Version (system): 1.72f1

I have followed all of the advised methods for problem resolution.
I could list them, but I don't want to be insulting or anything.

It just happened again. There's is lovely music playing. A sound of something like an insect (terribly disturbing by the way) buzzing around in the background, and when the insectoid sound starts or ends, it seems that is related.
I'm having a somewhat similar issue. I thought I'd chime in and send the report as well. I'm not having the lengthy freezes, rather it's for one second or less every 3-5 seconds, only out side and mostly when moving or turning, but not always. It seems to be affecting the whole system as well and WoW is not currently playing well with other applications using the internet in the background. e.g. watching a youtube video. Which used to work fine, no slow down in youtube or wow, now it totally bogs both down and generally interrupts (stops video, will not start again w/o reloading the page) youtube, though wow stays connected.

The problem is lessened if not gone when I'm inside an instance or not in a new MoP zone. If I'm in Org, I don't lag, though it still kills background processes.

I started playing with the graphics options. When I set the particle density to low, it seemed to clear up the problem. I switched it back to high and the lag was still gone. That seemed to fix the problem for a few minutes, but it eventually came back and after the 3rd settings adjustment, it no longer helped. It doesn't always happen for the first half hour or so of playing the game. Though restarting the application doesn't seem to help. Possibly a heat issue on the hardware side? WoW tends to run my MacBookPro (mid 2010) at 174º-180º consistently with the fans running at between 5600-6000rpm.

As with the others, I didn't have a problem that I can recall before this most recent patch.

EDIT: Updated to 10.8.2 yesterday with no change in performance.

EDIT 2: The game (particularly around Halfhill) became so choppy, it was almost unplayable. Earlier in the day I had dumped my Cache and WTF folders, turned all my addons off and on and finally set all the graphics options to low. I turned them up one by one and when I got to suns hafts, the performance started taking a huge hit (it was night at the time). Again, tweaking various things from addons to sun shafts seems to have a temporary effect of fixing the frame rate drops / freezes. They do seem to pop back up later. I'll edit this again if the sun shafts being off continues to help with the issue.

EDIT 3: The sun shaft fix only worked for an hour or so before it got bad again. After playing for a couple of hours, I was in the undead portion of scarlet monastery and had a freeze that seemed to keep trying to unfreeze. Audio would pop in and out and the screen would jump a little. After about a minute, wow finally brought down the system with it and I had to do a hardware reboot. When I logged back in, things have been working better for about 4-5 hours of gameplay. I did try rebooting before to rule out system issues as well as quitting all other applications (except for the G-series key profiler for my Logitech G13). I turned most of the graphics options back up to at least fair, many to good, sun shafts are still off as well the new lighting thing. Honestly, it feels like wow coughed up a hairball and is feeling much better now, after almost choking to death.


System Software Overview:

System Version: Mac OS X 10.7.5 (11G56)
Kernel Version: Darwin 11.4.2
64-bit Kernel and Extensions: Yes
Time since boot: 2 days 59 seconds


Hardware Overview:

Model Name: MacBook Pro
Model Identifier: MacBookPro6,2
Processor Name: Intel Core i7
Processor Speed: 2.66 GHz
Number of Processors: 1
Total Number of Cores: 2
L2 Cache (per Core): 256 KB
L3 Cache: 4 MB
Memory: 8 GB
Processor Interconnect Speed: 4.8 GT/s
Boot ROM Version: MBP61.0057.B0F
SMC Version (system): 1.58f16
Sudden Motion Sensor:
State: Enabled


NVIDIA GeForce GT 330M:

Chipset Model: NVIDIA GeForce GT 330M
Type: GPU
Bus: PCIe
PCIe Lane Width: x16
VRAM (Total): 512 MB
Vendor: NVIDIA (0x10de)
Device ID: 0x0a29
Revision ID: 0x00a2
ROM Revision: 3560
gMux Version: 1.9.21
Color LCD:
Display Type: LCD
Resolution: 1680 x 1050
Pixel Depth: 32-Bit Color (ARGB8888)
Mirror: Off
Online: Yes
Built-In: Yes
HP w2338h:
Resolution: 1920 x 1080 @ 50 Hz
Pixel Depth: 32-Bit Color (ARGB8888)
Display Serial Number: CNC9100WB4
Main Display: Yes
Mirror: Off
Online: Yes
Rotation: Supported
Television: Yes

Intel HD Graphics:

Chipset Model: Intel HD Graphics
Type: GPU
Bus: Built-In
VRAM (Total): 288 MB
Vendor: Intel (0x8086)
Device ID: 0x0046
Revision ID: 0x0018
gMux Version: 1.9.21


Input Source ID:
Keyboard Layout: ANSI
The reason I believe it is sound related is that it happens when there is a sound event. For example, let's say music is playing and then WOW abruptly switches to a different song in that way it does. This seems to cause a sudden 1 second pause.

Or let's say you're sitting there, doing nothing, not touching the keyboard and someone near you does something that causes multiple sounds, casts a spell or something, the sudden 1 second freeze with the sound being interrupted happens.

I just applied the very latest supplemental update as of yesterday, but the peculiar little freezes still happen.
Does anyone else have an apple TV on their network?

I noticed something weird in WoW where it select airplay for the sound output the other day. On a whim I unplugged my AppleTV in the other room.

When I was running heroics last night, I was not having the weird lag/freeze issues. Normally it would always happen in a dungeon as there are lots of sounds going on in there.

I still believe it is also sound related at this point.
Tried everything suggested and then some. *sigh* Hoping there is something to fix this soon, kind of putting a damper on my xpac fun.

System Software Overview:

System Version: OS X 10.8.2 (12C60)
Kernel Version: Darwin 12.2.0
Time since boot: 2 days 7:15


Hardware Overview:

Model Name: iMac
Model Identifier: iMac8,1
Processor Name: Intel Core 2 Duo
Processor Speed: 2.66 GHz
Number of Processors: 1
Total Number of Cores: 2
L2 Cache: 6 MB
Memory: 4 GB
Bus Speed: 1.07 GHz
Boot ROM Version: IM81.00C1.B00
SMC Version (system): 1.29f1


ATI Radeon HD 2600 Pro:

Chipset Model: ATI Radeon HD 2600 Pro
Type: GPU
Bus: PCIe
PCIe Lane Width: x16
VRAM (Total): 256 MB
Vendor: ATI (0x1002)
Device ID: 0x9583
Revision ID: 0x0000
ROM Revision: 113-B2250L-259
EFI Driver Version: 01.00.259
Display Type: LCD
Resolution: 1680 x 1050
Pixel Depth: 32-Bit Color (ARGB8888)
Main Display: Yes
Mirror: Off
Online: Yes
Built-In: Yes


Input Source ID:
Keyboard Layout: ANSI
To add to the conversation, I'm playing on a MacBook Pro mid2010 running OS 10.8.2. I've had no issues playing WoW until Pandaria came out. In fact, I ran WoW at the highest settings prior to this latest iteration. I have a severe lag. I play at the lowest setting, windowed, no sound, no voice, no other applications running in the background. I even had my 4 GB RAM replaced this morning - still lag. I have latency 105 ms (home) / 109 ms (world) / framerate 38 fps.

Even with these settings, sometimes I'll be standing still (even though I'm trying to move) and will jump 50ft. Flying is the worst. Playing PVP is the worst.

It's nice to see I'm not the only one with this issue. I don't believe that all these Mac users have Mac lemons nor do I believe that all of the Internet companies are messed up (Time Warner/Road Runner, Comcast, Verizon Fios). I would hate to wait until the next patch for this to be resolved.
I'm in the same boat. I have the same exact experience as Jaidyn. Same MacBook Pro, same OS, same type of experience with the settings, etc. Hopefully Blizzard gets this fixed soon.
So just to make sure it wasn't the laptop itself. I went into my bootcamp partition (Win7 SP1) and installed WoW and it runs perfectly fine from there. so it definitely appears to be a OSX issue.
It's happening to me as well.
This is happening to me as well...Cata ran in ultra settings on my iMac i3, ran like a dream..I've just bought a brand new quad core i5 and it cant even run on the lowest of settings without severe lag.

I've found that opening the character window will freeze/lag for 3 secs -2 mins and being in Org is constant lag pulses. Very frustrating Blizz...this should be sorted by now. I can be showing 139fps and still massive freeze and lag when I press 'c' or try to run around Org.

I've tried all of the suggestions from Support to no avail.

FYI those suggestions are:

"When in Launcher before hitting play hit the preferences button and switch from 64 to 32 bit"
"If option available try playing in DirectX 9" <-- No option for me on this one.

This game is simply not playable on a iMac with this bug :(
I'm having the same problem, too. Yesterday in LFR after a pretty lengthy screen freeze, DBM announced in chat that the fight was over and people were showing off their loots, while my screen was still playing the fight with the boss at 5% health.
Anybody had any luck with this problem yet? The lag still gets me in game, but it seems to be the worst after 12:00 PM.
I am having lag/freezing also on both of my Macs. I tried all of the suggestions given here and I also tried using the 32 bit client. I still have lag/freezing. The game is unplayable on my two Macs. I have no trouble or lag /freezing when playing on my Windows 7 PC.
I've been having this issue as well. I've gone through the steps listed of clearing my caches and such. I've disabled addons and cleared PRAM. I'm running the most current version of the OS.

I seem to notice this mostly when I am opening a window, such as my character screen, the achievment pane or my bags. Usually it freezes from between 8-30 seconds. During this time I am able to cmd-Tab out and do other things, so it seems limited to wow. This can happen to me anywhere. Less so in dungeons, but that may be simply because I am not opening windows much there. My lag almost always shows less than 200, usually less than 100.
Mine is an all out freeze up. It frequently come in battle or when looting. It can last up to a minute. The lag goes to 700 or 800. The game ping starts out fine then gets worse until I can't play. Restarting the game helps, but in a few minutes the lag/freezing returns.

System Software Overview:

System Version: Mac OS X 10.6.8 (10K549)
Kernel Version: Darwin 10.8.0
64-bit Kernel and Extensions: No
Time since boot: 4:00


Hardware Overview:

Model Name: MacBook
Model Identifier: MacBook5,2
Processor Name: Intel Core 2 Duo
Processor Speed: 2.13 GHz
Number Of Processors: 1
Total Number Of Cores: 2
L2 Cache: 3 MB
Memory: 2 GB
Bus Speed: 1.07 GHz
Boot ROM Version: MB52.0088.B06
SMC Version (system): 1.38f5
Sudden Motion Sensor:
State: Enabled


NVIDIA GeForce 9400M:

Chipset Model: NVIDIA GeForce 9400M
Type: GPU
Bus: PCI
VRAM (Total): 256 MB
Vendor: NVIDIA (0x10de)
Device ID: 0x0866
Revision ID: 0x00b1
ROM Revision: 3384
Color LCD:
Resolution: 1280 x 800
Pixel Depth: 32-Bit Color (ARGB8888)
Main Display: Yes
Mirror: Off
Online: Yes
Built-In: Yes
Display Connector:
Status: No Display Connected


Input Source ID:
Keyboard Layout: ANSI

I have been having it randomly since a couple days after the patch, but only a couple of days ago it has been affecting me nearly constantly.


1 ( 7.871 ms 7.080 ms 1.488 ms
2 ( 43.150 ms 46.004 ms 22.132 ms
3 ( 12.000 ms 47.387 ms 12.345 ms
4 ( 16.042 ms 15.129 ms 15.700 ms
5 ( 28.717 ms 22.824 ms 23.775 ms
6 ( 17.899 ms 20.414 ms 17.307 ms
7 ( 22.028 ms 22.685 ms 20.083 ms
8 ( 22.419 ms 22.221 ms 22.274 ms
9 ( 97.513 ms 78.961 ms 80.506 ms
10 ( 83.700 ms 79.730 ms 84.488 ms
11 ( 78.975 ms 80.114 ms 77.191 ms
12 ( 81.066 ms ( 80.512 ms 80.260 ms
13 ( 81.030 ms ( 116.042 ms ( 79.070 ms
14 * * *
15 * * *
16 * * *
17 * * *
18 * * *
19 * * *
20 * * *
21 * * *
22 * * *

Also forgot to mention above, mine is just weird, random latency that has turned into constant latency, since last night, not the freeze thing some people are mentioning. But I really think it is your guys' problem because this just happened randomly out of the blue last night and has been consistent since, where nothing could have occured from my end to cause this because my internet is testing great, my computer is working as normal as could be possible which is quite good, and this computer I only use for this game, SC broodwar, using safari for music on youtube or pandora and itunes, and for watching dvds. And this just happened randomly while playing WoW after a good 2-3 hours of great playing.

Join the Conversation

Return to Forum