Installer stuck at 0%

Technical Support
I recently got a new computer and wanted to re-download for to get ready for MoP when it comes out. The thing is the installer doesn't work. I click and install and everything then it says installing and just sits at 0% forever, as far as I can tell. I've read other posts about this and have tried all solutions, but still nothing. Is there anything other options? PLEASE HELP
Did you try deleting your cache, WTF, and interface files (don't forget to empty the recycle bin). Try right-clicking on your WoW icon and select "run as administrator". Mine stayed at 0% for about 35 minutes, then it hit 3% and after that it was quickly done. I then had some freezing/lag issues until I disabled all out-of-date addons. You might also consider shutting your firewall off and any "real-time" internet protection software you may have.

I do hope this helps!
This is a fresh install so I don't have any of those folders. I've shut off norton and everything that could be blocking it. Since this is a new computer I don't have any add-ons. I've also ran the WoW setup as admin. It's still sitting at 0%. Thanks for the suggestions though!
I have downloaded a patch that was at 0% for about an hour before finally moving so you have to be extremely patient. Also, if you have a Firewall it will completely halt the download. You have to click to allow World of Warcraft to continue downloading (in my case it is a popup in the taskbar and I have to select Unblock).
I've uninstalled my spyware protection software and turned off my firewalls, entirely. I'll just let the setup installer run while I sleep to see if it does anything when I wake up in the morning. Hopefully something will happen.

Try checking this out, if you haven't already. Basically just delete your folder inside C:\Program Data (if you're on Win7).

It did it for me, but once cleared out worked like a charm. It likes to do this a lot with D3 as well when they patch.
i had this issue myself i can vouch deleting the folder if needed helps out.
I have deleted the folder and still nothing :(

I should also add that all my WoW files are .temp files.
Hmm... now did you delete the C:\World of Warcraft\Cache or the C:\Program Data\

Just double checking since a lot of people get the two confused. The one under program data (or C:\Documents and Settings\All Users\Application Data\ if you're on XP) is a totally different file all together and tends to have issues with patching for some people. Deleting it essentially resets the Bnet cache. You usually have to go into your Control Panel and set your folders to "view hidden files and folders" in order to delete it.

If that's not it then idk what else to suggest.
I have show hidden files on and I've deleted that folder and ran the setup again. Still nothing. I guess this situation is pretty much hopeless.. Thanks for the help everyone!
Problem resolved!
How did you resolve it?
Macyntire, if you have any type of security program, please try each step below:

1) Configure your security program.

2) Disable your security program.

3) Uninstall your security program, and reinstall it afterwards.
Technical Support
'Constant change is here to stay.'
I'm having the same problem.
09/01/2012 02:10 AMPosted by Dolphinradr
Problem resolved!

How Did you resolve your problem???
What security programs or antivirus programs do you have?
Monday - Friday, 8 am - 5 pm PST
I'm having the same problem

I initially had a problem where the launcher would get stuck at initializing, with "Play" grayed out. -->

I tried myriad solutions (including deleting the caches folders, folder, Blizzard Entertainment folder, cleaning my registry, etc.), all to no avail.

Eventually, I uninstalled the game with the hopes of re-downloading it, fresh and without issues.

However, the installer became stuck at zero, and I suspect this is related to the cause of the initializing problem.

I am running Symantec Endpoint Protection on an 8 month old Dell Laptop with Windows 7.

I am trying to do all of this on my university's campus internet (wired), but I do not suspect this to be the problem, as WoW worked for months (up until a few days ago) without any sort of similar issue.
Update: The problem ended up solving itself. I wish I had some useful information to share, but I really don't think I do.

In case others can see a significance in this action that I do not though, after my first attempt at a fresh re-install, and the installer becoming stuck at zero, I:
1) Uninstalled the game again completely
2) Removed Curse Client from my computer
3) Installed all Windows updates
4) Restarted my computer (as part of the update process)

After these steps, the installer worked without issue and my game is currently operational.
so no real fix? i'm at the point that i'm hoping the 0.0% will just magically move to 100%
03/25/2013 01:17 PMPosted by Schlitzbull
so no real fix?

Hope so, im like a blonde when it comes to this kind of stuff.

Join the Conversation

Return to Forum