stuck: checking for updates .......

Technical Support
So my computer has been stuck on this white box, which is the World or Warcraft Setup

There is a logo to the left screen wth a disk.

There's no bar movng but the dots are.

How long is this likely to take? Anyone know.......
I'm not sure exactly what you're talking about but it shouldn't take too long. If it's the prepatch setup I believe the launcher states it should take from 15-60 minutes. If it's been going for 90 minutes then I'd start to worry.
I recommend either restarting the launcher or attempt to start the game from wow.exe
I've never seen this box before either, it kicked in after the main screen had finished its download
An error message was displayed :

Could not write storage You may not have permission to write to the destination path. Please check if another application is running.

Hmmmmm, I have no dea what that means :s
I seem to have resolved my issue, please see my other thread

Please try this - "World of Warcraft-Repair" thread title
im stuck in a loop of trying to start the game then it just disappears keeps saying checking for updates, then needs my permission to continue, then when i give it after like three times,, the whole game just disappears, ive shut off all my virus protection etc but still no luck any suggestions ?
I'm having the same problem, it only says "Checking for updates..." for maybe 5 minutes or so, and then stops and gives me this error.

"Failed to run a required program (Agent). Wait one minute and try again and if that doesn't work please restart your computer and try again."

Error Code: BLZPTS00007
been stuck updating setup files for 2 days solid now is there something bugged out on blizzards end or something ... i have a dedicated company T1 line and i can easily pull 500mb per second from any other down load so whats the deal with this one?
http://us.battle.net/support/en/article/BLZAPPBTS0000K

check this out it just fixed the issue i was having
I was having the same problem so I bypassed the launcher. Open up the file location and just run WOW instead of WOW Launcher. Worked for me
same here and its really annoying, if you find out how to fix it please let me know
If anything acts goofy like that on startup and you're running Windows 7, try right clicking the icon and clicking "run as administrator". This will usually fix most file permission issues and misc. startup issues.

Join the Conversation

Return to Forum