Right Mouse Click Camera Movement Issues

Technical Support
After this most recent patch came, I have had a strange error pop up that was never present before. When I am attempting to move the camera around holding my right click, to shift my view angle and what not, a large portion of the time the click won't register properly, or it won't hold.

For example, I am standing in Stormwind, I hold down my right mouse button, slide my mouse to the right for a camera rotate, and absolutely nothing will happen. No movement, my cursor just goes across the screen as if I am not clicking at all. The second issue will happen while I am in the middle of a camera turn. I will be turning, button still held down and everything, and it will just act as if I let go of the right mouse button and stop turning completely.

I am using a Razer Naga, and I went and completely reinstalled all the drivers, did everything I could think of for it today, with no success. I turned off all my addons to see if that was it, still no change. This problem does not appear in any other game or anywhere outside of WoW. My right mouse clicks register 100% of the time in every other application I use them in.

I'm really at a loss for what to do now. I don't really understand what could be causing this error, and it is making gameplay extremely difficult. Half the time when I want/try to turn I don't turn, I'm sure you can imagine that that has somewhat of a large impact on gameplay.

Any advice or help is appreciated, thanks.
I would like to Report the same problem with the Logitech Gaming Mouse G500 (Wired) , at first I thought it was a hardware or windows program problem but after a few test and running other programs it seems to only happen within the warcraft windows. Even in full screen mode. It doesn't always start with the problem but after a few hours the problems starts. It also 100% happens when I do Alysrazor the flying phase.

Advanced > Hardware Cursor option has no affect.
This same issue is happening with me. I am using a Logitech g500 mouse. The right click works fine in all other applications/games. I play in windowed mode.
Same problem for many ppl
Same problem. Have tried a couple different mice.
I'm also Having the same Issue. Using steelseries cata mouse
Exact same issue. Tried several different mice. Is Blizzard going to address this?
Did you enable hardware cursor and the reduce input lag options in the interface options? If so does it resolve the issue when you disable them? I am curious because I am seeing a lot of people having issues with the mouse including myself having an issue where sometimes when I try to pan my camera with my right mouse button is does not register the click therefore sometimes I am unable to pan my view which severely impacts game play.
And I was also wondering what video card do you have? Thanks.
Same issue here as well. I'm happy you made a thread about this issue, because I thought it was me for the longest time lol
I've had this problem with my g500 and am glad to hear its a wow issue because i was goign to replace my mouse. Plz someone help with this because it sscrewing me in pvp
Oh my god. I thought it was my mouse dying.

Same problem with a Cyborg MMO 7. Also sometimes when I press both main buttons down to move forward, nothing happens. Also also NPCs and other interactive objects have become really hard to interact with.
I had this problem as well before. And as of recent it started happening again.

Back in cataclysm, I reinstalled and that fixed it. But who wants to do that, honestly?

Not I.
So this is still happening and I typed in /fstack to see if it was a frame issue. The only time I'm getting this issue is when my mouse is over SpellActivationOverlayFrame
I am having the same issue. About half the time when I either use left or right mouse click to turn my camera angle its not responding to the click. The mouse travels across the screen like I never pressed the button. I have to Logitech G500 mouse.
same here , blizzard plz fix this
I'm having this issue as well, I've tried a brand new mouse and the same problem occurs. It happens primarily on my rogue and has made him virtually unplayable until I find a way to stop this from happening.
Same issue here, I would like to add that it only happens to me when I click in the middle of the screen. That is, the click fail rate in the outer parts of the screen is 0, while if I try to move camera by clicking in the middle portion of the screen and dragging my mouse, it fails to register the click like 30% of the time.

Has anyone find a fix? It's so annoying...
Guys!!!! I fixed it... At least for my case. It was bartender. I had some activated (but empty) bars in the middle of the screen. These parts of the screen were dead spots where clicking to move camera wouldn't work!
I just bought my G500 less than a month ago, I am having the same problem with the camera. Did anyone find a successful fix?

Join the Conversation

Return to Forum