Missing AddOn Button 5.0.4

Mac Technical Support
I've updated WoW, the Curse client, and my addons but I don't have the AddOn button on my character screen. I couldn't find an addon option within the game. It looks like the addons are in
WoW-> Interface -> AddOns. I've also restarted any system and operation I can think of.

Any ideas or idiots' guide?
Looks like I figured it out; the shortcut wasn't being linked to the normal WoW folder and was creating new files every time it was opened. Made a new shortcut from the WoW folder.
I'm glad you figured it out, but mine is still missing, even after making a new shortcut from the WoW folder. Is there any further advice from anyone?
I would love to get an answer to this as well. I've had mine show up a couple times when I had the old character background but when it shows Orgrimmar in the backdrop I get no Addon button. Hmmm, hope we can get a fix for it soon.
I too am having this problem. It was that if I loaded the Wow-64 way I would get the old background but have my addons, now it doesn't matter which launcher I use, my addons are gone. Very frustrating when I am needing to raid. Any suggestions would be appreciated.
How are you opening WoW? From the desktop?
With the either the world of warcraft-64 launcher or just the regular Would of Warcraft launcher. Up until this afternoon I could launch with the 64 launcher and get the addon button, after this afternoon I can't even get it with that launcher.
and today I kept getting dced with an error notice when I tried to loggon, my character was in stormwind. I sent the errors to wow. I tried to find the repair.app but saw it was deleted with the last patch.
Can you verify if your WoW folder looks like this: http://i50.tinypic.com/2isuxch.png
Mine only has the World of Warcraft Launcher listed...not the World of Warcraft, or the World of warcraft-64
09/03/2012 12:42 PMPosted by Teaneetiny
Mine only has the World of Warcraft Launcher listed...not the World of Warcraft, or the World of warcraft-64

This is why. Please put those back into that folder and instead create an Alias to use as a shortcut: http://support.apple.com/kb/PH10609
done, but still no addon button
K, so when launching from the World of Warcraft launcher inside the WoW directory, the add-ons button is still missing? Did you add any add-ons in there lately?
I'm able to access wow, and I'm able to log on. But when I go to place addon's in my addon folder. It's.. gone? I had to uninstall and reinstall wow upon the new patch.
The only known folders it's showing at Data and Temp folders.

>.>;; help?
I have this issue as well. I just did a full redownload of the game. If I launch the World of Warcraft 64 or the Launcher I still see no addon button on my mac.
Have you added any add-ons yet? If you haven't, then the button won't show up.
see i have no addon button either i have no idea if this is new or not because i was never really into them but i was shown how useful some can be today, the friend who showed me tried to add some basic newly updated ones that he uses, and pow no addon folder, im been scowering the net for an answer to no avail, i have no idea whats wrong or where it is i even tried just making a new folder called addons to no prevail as well. plz help
cant find anything still looking hard
For those having issues, make sure your addon folder looks like this (your addons will be different than mine):


If you see only the Blizzard_UI addons in there, then your addons are installed in the incorrect place.

Edit: Pardon the WinAmp in the picture - it forces a "float above all others" mode when used in CrossOver.

Official Mac Tech Support Forum Cookie™ (Mint Chocolate Chip)
Guaranteed tasty; Potentially volatile when dipped in General Forums Syrup®
Caution: This cookie bites back.

Join the Conversation

Return to Forum