Outlands Loading Issues - Please Blizzard!!!

Technical Support
Ever since the 5.0.4 Patch I've been having serious issues loading Burning Crusade Content (Zones, Dungeons, etc.). I've been reading the forums all day and I couldn't find any real support on this issue from Blizzards end.

I've heard several different suggestions to solve this:
- Delete Interface, Cache and WTF folders.
- Reduce Liquid Detail to Low.
- Uninstall 3rd Party Addon Installers.
- Disable Antivirus.

After reading some posts from people who seem to have fixed this I decided to take the simplest approach I could. I renamed my Interface folder so as not to lose any of my addons and I deleted my Cache and WTF folders. As soon as I opened up Wow.exe I reduced the all Graphics slider to Low and changed Display Mode to Windowed.

Once logged in I tried my Druid which was stuck on the Zul'Aman Loading Screen and it zipped right through without issues. I had also created a Draenei Shaman earlier on today and I wasn't even able to load Azuremyst Isle in order to play on this toon. So I tried logging in as this toon since it worked so well for my druid. Same issue again - Got stuck at about 50%. So I deleted the Cache, Interface and WTF folders again. Loaded up Wow.exe. Reduced Graphics and tried again on my Shaman. This time it looked promising... Until about 80%. Got stuck again for about 2 minutes and then kept loading until about 90%. Got stuck AGAIN for about another 5 minutes and then finally loaded.

Some things still seem to be noticably glitchier in BC content than anywhere else. Like sound is crackly, UI loads alot slower. Environment detail is questionable, etc. Not sure if this is just a result of deleting the cache though.

Can we PLEASE got some kind of a responce from blizzard?! Some kind of acknowledgement that this is a serious issue and that they are addressing this to find the source of the problem? This should be among the high priority as there are so many people faced with this.

I think I speak for everyone when I say we just want to know what is causing this. Please Blizzard! Don't let us down =(
I am having the exact same issue post patch, what should I do?
Same Idk what in the world is going on
Same :0(
same mine keeps popping up couldnt load blizzard talentUI: corrupt. please blizzard fix this
I'm having this issue as well, and have tired all the things in the op's post to no avail.
I'm also having the same issues. I was simply running around in outlands starting in Hellfire Penn. and the small downloading important content icon popped up. It was yellow at first and as i got farther into the zone it turned red and the buildings/land/npc were not loading at all. I was actually having to stop flying because i was at a blue line and couldnt pass until it was loaded. No idea whats causing it to happen.
i have the same problem. stuck on loading into outlands, the dungeons work if i go though the instance queue. every other zone loads in 5-10 secs (ssd) but this one either 1 takes 5-6 minutes or 2. doesnt load at all just gets stuck
Same issue here. Tried many things and nothing solved.
I also notice other posts about this issue, and no word from Blizzard at all.

Can we get a Feedback? Outlands is Unplayable.
Bumping threads from months ago causes a bit of confusion. If you need assistance with an issue, please create a new thread and detail your issue there. Make sure to include any steps you have already tried.

Join the Conversation

Return to Forum