WoW Optimization Stuck at 0%

Mac Technical Support
I opened WoW today fro the first time in about two weeks, so nothing 5.0.4 related things have been installed yet. I opened the WoW Launcher and it said Downloading Updated Tools. The bar got full and it opened a 2nd Launcher that was the WoW Optimization Launcher. The message under where the download bar is supposed to be says Reconfiguring Game Files. Please Wait. I've had it open for about 4 hours at any given time. It stays at 0%. PLease help me. Thank You in advance.
Try this and see if it helps. Make sure WoW is closed.

Deleting the
    1. Navigate to Macintosh HD/Users/Shared
    2. Delete the folder
    3. Launch the World of Warcraft Launcher
Am having the same issue and following your instructions isn't working.
Edit to add: as is my husband.
Same here >:(.

Running a mac OS 10.7.4

Tried your suggestion with no improvement in the problem... I R sad...

Thanks to anyone who can help us out with this.
We are sad pandas Machkan.
Same here stuck on zero even tried downloading in safe mode
Hi all,

I also am on mac and I am running 10.8.1 (awesome upgrade to mountain lion btw for those that haven't made the jump). I was having the same issue and I did two things:

1) like Machkhan said, delete the folder that he references.

2) I had noticed when trying to do this that a lot of boxes were popping up requesting permission to allow the install files to either access the hard drive or the internet... It did not matter if I had the firewall on or not. However, they were going away faster than I could hit the 'allow' button, and then the installer/optimizer asked for the my account password to do the installation so I thought it wasn't a problem. It wasn't until I finally hit every stinking permission to 'allow' as they were popping up that this optimizer finally ran and completed. I believe there are 4-6 of them. I would recommend running it and seeing if you get lucky, if not find a way to figure out where you need to have your mouse cursor so that it is ready for the 'allow' button and run it again making sure you get them all. If you get them all, some additional files will be downloaded and updated....this didnt happen on the tries when the optimizer got stuck. Once the optimizer pops up and actually goes to work, you are done and can leave it to run. I have no idea how to do it any other way and I reduced all the permissions on my machine to a free-for-all in an attempt to get around it and nothing worked.

I hope that helps someone out. I've been trying for a few days now and it has been quite the challenge. Also, once the optimizer did start to run, it still took a good 30 minutes to complete (I have a fast and powerful imac circa feb 2012, so its just a tedious process regardless of equipment). So don't get discouraged, as long as it moves off the 0% pretty quickly you should be good.
I have Mac OSX Lion 10.7.4 and and the steps didnt work
We're still looking into this matter, as it seem in some cases this doesn't work.

For now, if the issue still persists after troubleshooting, and you want to bypass this process all together is to uninstall the current version of the game and reinstall using the new 5.0 installer from This starts the game off at 5.0 so you don't need to do the optimization process.

You can find how to uninstall and reinstall using the new 5.0 installer here:

that is your answer to fix the problem?

delete your existing game folder and download everything all over again?

did you test this optimzation stuff before releasing it?

dont you find it interesting that so many people on both Macs and PCs are having the same problem?
It doesn't make any sense why WE have to do this. Shouldnt we just be able to use the optimizer without any problem? The hell are we paying 15 dollars for?
Running 10.8.1 on a 2.5 GHz Mac Mini.

The solution of deleting the folder in /users was the solution I needed. Thanks.
I tried what Machkhan recommended in his first reply (second post from the top), and that worked for me. The optimizer is now running.
I am running OSX 10.6.8

Blizzard really dropped the ball on this one!
I had the same problem on OSX 10.8.1 and spent the better part of the last 24 hours trying to fix this. What I did to fix it was to restart my computer and then log onto a different wireless connection. I have a dual router so it wasn't a big deal for me. Once on the different connection, it started downloading the first time I tried it.
So for my understanding Blizzard released something that is not working 100% and have the public deal with it? what kind of !@#$ is that? and to fix the problem they tell you reinstall everything so people spend a week on problem and than another few days on reinstalling this HUGE game while 15$ that was paid for a month is getting wasted. Will Blizzard refund that money? will they give few days to play time? nope they just take your money and give you broken game for you to figure out how to fix. Amazing what this company has come to.

Ohh and this optimization process has been stuck at 0% for 17 hours now, ive tried everything that was on Blizz tech support, forums and internet. Nothing works
I got mad and closed the launcher.. then optimization started and is working just fine

Try reversed psychology, its great. "Don't close the launcher!"
I uninstalled and then reinstalled wow and that worked fine for me.
Delete the game and reinstall it is not going to make it for me, my internet line is not that fast. I work on a software developing company and a mistake like this should be addressed on a hotfix real soon. Making people perform a full reinstall is a great way to lose costumers.

We need an option on the launcher to skip the optimization process as a quick fix.
@Kyres I did mine overnight and when it finished i didn't even need to optimize. You don't have to wait long if you are sleeping through it!
There isn't an option to bypass this, as this reconfigure files for the base 5.0 file setup and patches from there.

As mentioned before, this is still being investigated, and if you've tried the basic troubleshooting that is available, then currently the only alternative is to attempt a full uninstall/reinstall and see if that helps.

I know that this is not ideal, as this is mainly a last resort, but for now, it seems this has resolved many patching issues.

Join the Conversation

Return to Forum