WoW Optimization Stuck at 0%

Mac Technical Support
I made it work using a different way, my steps here:

Deleting the
1. Navigate to Macintosh HD/Users/Shared
2. Delete the folder

After that did NOT open WoW, I emptied the trashcan, run CleanMyMac, to remove a lot of the junk the failed installs (I have been trying to get this optimizer run for 4 days already so a lot of junk there), rebooted my Mac, run once again CleanMyMac.

After all of this, I open the WoW Launcher, and moved from the optimization phase and is now downloading updates.

I just wanted to share this in case somebody else want to do it, it a Mac/OSX only tip :)

@Hanhan, I know, but well I wanted to play during the weekend :) since I was on a certification training and have not been able to play for quite some time.
On a mac OSX here, deletes the file and opened WoW launcher, this re-opened the optimizing page but currently up to 4% when before it wouldn't budge from 0%. Will keep updated.
Just an fyi so others are aware. I decided to just reinstall but when I went to it said my account was locked because of suspicious activity. I heard this happened to someone else. Apparently trying over and over again can get you flagged. Didn't take too long to reset but still feels kind of insulting to be flagged because I've been trying to patch.
Patching shouldn't have an affect on something like this, as you aren't required to log into to patch.
I had to delete the contents of the Temp directory in the World of Warcraft folder in order for optimization to start working. Note there is a known display issue that keeps the optimization at 0%, even though it's working.
Thank you this worked for me now the % is moving :)
I was having the same probs as well....Tried the above fixes and now downloaded 74% so far.....Fingers crossed I make 100% and be able to login in with no more problems....

82 Blood Elf Mage
Crusaders Of Time
I got mad and closed the launcher.. then optimization started and is working just fine

Try reversed psychology, its great. "Don't close the launcher!"

Wow, most excellent.

Tried the same thing and now the optimizer is running.

(Before trying your simple fix, I did numerous "Sample Process runs" and ran "lsof" to see what files were open. Nothing indicated the optimizer was doing anything, and everything indicated threads stuck on waits, selects, or message traps. It sounds like Launcher was holding open a resource the optimizer needed to continue so quitting Launcher released it and allowed it to continue)

ps, this was my first 5.x run on 10.8.1. I also was a MoP beta user but hadn't ran that for months either
any one know where i can find the wow installer download. the site is down...
This should be up and running now:
Working, thanks :)
This is what worked for me. Worked instantly actually.
I've struggled with this for a while now. Tried re-installing, which did nothing. Then I found Valaire's post about getting mad and closing the launcher, which is specifically says not to do in the optimizer and now its working like a dream.
Fixed on my Mac in the following manner:

1. Quit the launcher, even though it tells you not to.
2. Force Quit the process named "Agent". Great naming btw, Blizzard. Not generic or obfuscated at all. Very specific as to what software package that belongs to. Can you please not do that again?
3. Relaunch and let it optimize.

Went from stuck at 0% doing the square root of Jack, to spikes of 513 MB/sec of disk activity.
This was a close call. Due to the constant jumping through these hoops and all the times I've have to sit at my PC and endlessly research solutions to problems with this game, I (like countless others) said screw it and just quit playing to alleviate the stress of such issues.

Over the course of time my friends been pushing me to get back on and I had forgotten about said issues until I launched the program and POOF like magic all the memories of all the bugs and hours wasted finding answers came flooding back. I think I'm going to skip it this time. I'm going to play something else.

Don't get me wrong. I love this game. You just have to admit that when 30% of your time with this game is spent at a downloading screen or a fix forum or staring at a bug report... it starts to get a little old. Heres to the times when I did work. Cheers.
I got mad and closed the launcher.. then optimization started and is working just fine

Try reversed psychology, its great. "Don't close the launcher!"

this worked for me as well!
This is just frustrating. I live in the country, with only 100kb/s internet, It takes me a VERY long time to do ANYTHING. In fact, to reinstall the game, I just bought all of the cds again in a hope that I could install the basic files and save myself 20gb of patching. Unfortunately, blizzards cd's are only good for coasters, because they all just install the patcher that makes you download the entire game even though the cds containt about 7g of data. Why the hell would they even sell cd's, just sell the cd keys and save the planet. smh.

Join the Conversation

Return to Forum