WoW Optimization Stuck at 0%

Mac Technical Support
I got it to work in this fashion:

I closed out the Launcher.
Using the Finder I located the folder (actually, I had 2 of them) and moved if (them) to the trash.
I then attempted to empty the trash.
I clicked 'continue' to bypass the alerts that popped up and the optimizer started to work.

I hope this helps someone.
Hanhan I did the same thing. I slept through mine. I installed it from the website. I downloaded the installer and it worked perfect.
i initially had the same problem, and i don't even know what i did that fixed it - but i just disregarded the warning not to close the window, and tried the process multiple times. finally got it to work around the eight shot, but it's slow as hell; been open for 15 minutes and it's currently at 0.4%. oi...
I've done everything (except a reinstall) to fix this problem. I've followed everyone's precise directions posted here. Nothing. Even called Blizzard, told me the same "solution" I saw here. I'm not going to reinstall 7 years worth of patches and updates. Surely there is a more efficient way around this problem.. Not to mention my internet is total garbage. So re-installing such a large game doesn't sound all that appealing to me. From what I've read, Blizzard is investigating and looking into this. That post was about a month ago. This isn't a petty issue. There are many, MANY, people experiencing this exact problem and in my opinion, they should be pretty serious about fixing it. There is nothing I would love to do more right now than play MoP..
This is something that seems to be affected by different factors, which so far the steps have helped in some of the situations. Yes it is being investigated still but nothing definitive has been determined yet.

This is why we recommend reinstalling to bypass the whole migration process until something definitive is found.

The "7 years of patches" actually gets repackaged every expansion lately, which is what this migration process is doing. So what this process is really doing is compressing all the 4.x files into base files and then downloading the 5.x data.
I did the "delete" folder idea
I had problems with this topic as well
I updated to latest OS 10.7.5
deleted the folder. and it started to work

agentclient.log keeps getting overwritten.\ Launcher.1857/Logs/agentclient.log
keeps getting over written, and is normally zero bytes in size, not sure if this is by design. But its hard to read it. I had to repeat cp to another location , and checking the size so that i knew i had copy of the content. ie
cp\ Launcher.1857/Logs/agentclient.log /tmp/agent.log; ls -l /tmp/agent.log
this happened both when it was stuck at zero and when it finally worked
1. Navigate to Macintosh HD/Users/Shared
2. Delete the folder
3. Launch the World of Warcraft Launcher

Deleting "Macintosh HD/Users/Shared/" doesn't work.
But you will also find another;
"Macintosh HD/Users/Shared/Blizzard/"
Deleting this folder will work.
This worked for me, thank you
Anything else been figured out on this issue? I ran the optimizer on my older Dell laptop last night and it took awhile, but it was done in the morning. And I could see progress, it was up to 7% when I stopped watching it, which was about 15 minutes after I started it. I've been trying all day to run it on my husband's Alienware to no avail. Stuck at 0% for hours. Have tried all the suggested fixes listed. I'm getting really sick of having to spend hours looking for fixes all the time. I haven't played in several months, a friend just started so decided I would get back on for awhile, but now I'm starting to think that was a bad idea. It took me 6 days to get my lost authenticator removed from my account and now this.
my WoW optimization is stuck at 0% but then again this is my first day back..... i just wanna play

p.s im on a windows vista.
I had this issue too - deleting the WTF, Cache, and Interface folders fixed it.
Mine was frozen at 0 percent for 2 hours. The second I closed the launcher, optimization jumped to 2.1 percent and is climbing slowly.
I tried the first thing you said, but forgot to empty the trash. After doing that it worked. Thank you.

And everyone complaining about uninstalling and reinstalling... seriously, guys? you spend 100s of hours on this game. Whats another hour or two to do this so you can get back on and spend 100s more? At least it's free and everything you need is at your finger tips. The guy said they're working on it. Complaining won't fix it. If it's that bad, unistall it, and when you start fiending for your azeroth fix, reinstall it. And guess what: it'll solve your problem, too. ;)

Thanks Blizzard for making my favorite game. You can sleep with my wife, and I'll probably still keep playing :P
Just wanted to say I completely deleted anything WoW or related from my computer and then reinstalled the client from the website and it finally is downloading! I have a mac and I haven't played wow since March. Just figured I'd add to the forum that helped me :)
Deleting the folder on my Mac seemed to do the trick.
Uh... I closed the original launcher window as suggest in previous posts... rolled my eyes at it but I figured it certainly couldn't make things worse, closed the launcher- then it immediately changed to above 0%. The context says not to close the launcher, which I assumed to mean any window to do with the launcher... however now I expect they meant not to close the optimization window, because obviously that would stop the process and perhaps in a bad way. Either way you shouldn't HAVE to close the old window to make it work.

I'm not entirely confident this will resolve my issue, but the percentage completed moved to 0.1% right after closing the original launcher window.

I'll post back if this didn't truly resolve the issue. Running a 10.6.8, 2.4 Intel mac.
Im stuck at 0.1%, I tried to delete both of the folders and i had emptied my trash but it does the excact same thing.
Note: I own a PC im saying this because eveyone els here seems to own a mac
tried downloading on new computer, its been on 0.0% for atleast 40 minutes :(
This did not work for me at all.

Join the Conversation

Return to Forum