Can't DL/Connect (Students Pt. 4)

Technical Support
Prev 1 2 3 4 29 Next
Still nothing :( I can only log in with hotspot.

EDIT: On a brighter note, the website is cool looking :))
I just tried two of my lowbies like 1 and 6 and was able to log perfectly, but I tried my 85 and same deal started but i let it go for a min or two and tabbed out but now i'm in in dalaran on my 85 druid- coming at you from SD State....
-correction i logged in, seemed fine but trade chat is working but character/abilities lagged out

-EDIT lat is at 1330 home,73 world
Hopefully blizz can have this fixed, like they said they hope to...
I still can't :)
Friend of mine having this issue as well from his college campus.
I expect to be reimbursed for all this wasted game time....
I remember when WoW launched, and Blizzard did reimburse people with free game time. Because back then, they cared. Now with a publisher that has their hand in the feed bag, it's just about money. Don't expect to get anything from Blizzard these days. If you deny Blizzard hasn't moved to a max profit scheme only...I point you to Diablo 3. Epic failure.
still nothing? :-/
Nope. I know for a fact I used to be able to play where I'm at as well. Then it changed with the patch. This also happened with Diablo 3, then one day "magically" I could log in and play that too.
So one day, we will "magically" be able to play WoW as well?
09/07/2012 02:12 PMPosted by Codymano
So one day, we will "magically" be able to play WoW as well?


It happened to us at Kent State, however, I do not know if that is the works of Blizzard (unlikely) or my school finally getting their act together
Ugh.. I still can't even download the game.... :(
09/07/2012 01:40 PMPosted by Inbox
I expect to be reimbursed for all this wasted game time....


^^Amen to that.
09/06/2012 08:18 PMPosted by Tambahali
Reporting in from Temple University. Blizz please get your !@#$ together.


Don't know what dorm you're connecting from, but in Towers the LAN connection lets me play!

And the response i posted on the first page of this thread is our IT dept, just in case you want to know Temple's stance.
What is this thread doing on page two? come on now.
The thread is depressed. :(
I think the couple days that I could connect was just because my school took down their packet shaper or something. I was also able to access GW2 and Minecraft those days (both of which I gave the port numbers too IT, and they said they would be allowed in the next patch), but now I cannot.
I went home on 8/31 and updated the game from there and have been able to play since then. But all of a sudden today I come to log in and now it's back to updating files and going nowhere..?

FFS Blizzard, get yourselves together or give everyone a refund.
Bump to fix the problem
Bump for the night

Join the Conversation

Return to Forum