Zboard want work

Technical Support
The Zboard is not functioning since the update mainly the auto/run key
Not supported by Blizzard. Look for an updated driver from the manufacturer.
have you found a update that works for the zboard yet ?
I'm having this issue too. Would love a solution as it makes things so much quicker moving between chats and whatnot.
check here for a driver update. Unfortunately the current one was made back in May so it more than likely will not work.


Alternatively you can contact Steelseries tech support to see what they suggest at
I contacted them and they have no idea either :/. They told me to try and disable my UAC and see how that works. Basically a guinea pig until they figure it out. My enabled light on my keyboard doesnt light up so i know something is very wrong since the patch. How annoying >.<
I was so upset my keyboard stopped working I ...

I hope this will fix your problem, on my system is 64bit and this worked great.

open ZEngine software

1. in the first box on left right click and copy the mod
2. go down to custom mode box and right click then click on paste (game)
3.click on tools at the top and then click on skins.
4. at bottom of box that open select "do not use skins" and click restart
5. when zengine restarts go to the mod under custom mods and right click and click
on "Edit Game Executable"
6. click on remove, then click on the box with the three dots and navigate to your World of Warcraft folder then scroll down and find WOW-64 select it and click open, Add, then click close.
7. go back to tools then skins select load game skins click close and see if it works.
8. make sure you have the new custom mod selected.

I hope this helps everyone and good luck
Tried this out and it worked my Zboard is back up and running though the Enabled light doesnt light up but everything else works fine for swapping between chats and whatnot it took a few attempts to get it right as the little box on the bottom left side of the screen for custom mods as barely visable, but if you follow what Shamad here has posted it will work :) thanks for the help
Thanks Shamad, I tried what you suggested and I was able to get my Zboard working again. I've been using it since BC and its good to know I still don't have to replace it yet.
Shamad, you are a GENIUS!!! It worked!!! WOOHOOO!! Now why couldn't the guys who sell the thing have put that on their website....Once again, ty Sham...you're a gem.

Join the Conversation

Return to Forum