Loot/Target Bug??

Bug Report
Prev 1 2 3 12 Next
Same problem, happended to me when i tried to return a flag in wsg =/
Same here. Add me to the list. There seem to be many threads related to this bug.
Same happened to me today and yesterday.

Yesterday was on the AH NPC in Valley of Wisdom, and today it was on picture that I needed to loot for the quest "Of love and family" in Stratholm.

Tried reloadingUI, logging in and out, and disabling all addons.
This happened to me on this particular character a few times last week while I was questing in Mt. Hyjal. Both herbalism nodes and some harpies I was just unable to interact with at all via mouse-over or clicking. Logging out and back in would fix it each time, just for a little bit.

I didn't encounter this issue yesterday, or today, yet.
I'm having this exact same problem, glad i'm not alone.

NPCs, mining/herb nodes, enemy players, mobs, etc.. randomly untargetable. And again, the exact same fix for me, having to log out and back in usually allows me to click said object, but /reload ui does nothing.

It's getting worse for me. It started on patch day as a flight path untargetable until i relogged. Then, day 2, it became a few mobs throughout the day I couldn't click target, had to use TAB, but now it's just terrible - being forced to log out at least 8 times an hour just to turn in a quest or mine a node.
I'm having similar issues, but not quite the same. When doing dailies in Tol Barad, I'll randomly have croc corpses that I cannot loot, skin - or even target at all - despite knowing full well that there should be a hide on the corpse to pick up.

This isn't a case of AoE looting already getting the item off the corpse, either, because when it happens it'll be just the one mob, and it'll be the only mob that I've killed in an area TO loot, and it happens when I'm solo so no one else could have already looted the mob.

I haven't noticed the issue with anything other than the crocs, but then I haven't run much that isn't dailies this week, either.

This exact thing just happened to me in TB.
i am also haveing these same issues its been going on since 5.0 went live and truth betold i also have this issue on the beta ..also last night i killed 2 mobs couldnt loot..loged out then back in still couldnt loot tryed killing more near my last kills an still couldnt get loot this needs to be fixed .a.s.a.p seeing how we are starting to see bugs that shoulda been delt with in beta
I have the same issue and it drives me NUTS. I have 10 accounts so I'm leveling 10 toons at a time and it's a pain to loot. I have to log off/on with some toons in order to loot.

Blizzard if there's any bugs you should hot fix THIS IS IT!

You may be running out-of-date addons, that's usually the primary culprit of issues with being able to click or loot things.
This was happening to me as well so i tried disabling some addons, Fishermans friend was causing this problem for me.
I'm having a few of these, cannot loot mobs or catch fish. Logging out and back in has fixed it so far. It would not go well in a dungeon though.

I better say that mine was after I had looted mobs and fished up things for a while, then it just stops.
Would it be possible to know some other culprits please?
It's not add-ons

09/04/2012 02:31 PMPosted by Sapperwix
You may be running out-of-date addons, that's usually the primary culprit of issues with being able to click or loot things.

I am having this problem and I do not have any add-ons.
I wasn't able to click on a mob that i needed to use the item on the corpse of for a quest for my alt. Also was unable to click on jeeves so that caused an issue.
This is not an add-on problem. I have experienced this bug in Molten Core twice now since the patch went live and do not use add-ons.

First, there are mobs that you cannot target (seemingly random, since it does not occur for every type of the same mob- but especially for mobs up against walls). When you mouse over the mob, a sword does not appear, and only the mob can therefore initiate aggro once you enter its range. Second, once this type of bugged mob is killed, it may sparkle, but you cannot loot it. A player can manually log out and back in right away and loot it that way- each time! Also, sometimes these mobs- along with mobs that are targetable- just die and do not sparkle (i.e., a player gets no loot). I have logged out and back in, but there was just no loot to be gotten. This has happened to me especially with Core Hounds and Molten Giants/Destroyers. I have experienced all of these bugs in Molten Core and only in Molten Core since the patch went live.

Prior to the patch, the only similar problems I had were with air elementals in Wintergrasp that were located right on the border of that zone with Dragonblight. Sometimes they would phase out as I approached or else I just couldn't loot the sparkling corpses without logging out and back in. I chalked this up to a terrain issue, but now that it's happening in a more drastic and varied form in Molten Core I am not sure what's going on.

Edit: Spelling changes, and also to note that I have sent in multiple Bug Reports about these problems since the patch went live last Tuesday. Also, the chest in Molten Core following the Majordomo Executus event was lootable last week but not tonight. I am not sure if this problem is also related to my above comments about looting/targeting in the instance.
This isn't an add-on problem, though it can appear that disabling add-ons fixes it, as relogging fixes it.
I believe the problem I reported at http://us.battle.net/wow/en/forum/topic/6490600304 is related.
09/04/2012 02:31 PMPosted by Sapperwix
You may be running out-of-date addons, that's usually the primary culprit of issues with being able to click or loot things.

Having these issues in BGs, being unable to grab, target, click on flags as well. Not running any add-ons at all.

It's pretty random as to when it happens. I'd say prolly 1/30 times the flag doesn't even give the icon to click on it.
I do not use add-ons when a Xpac prepatch and i deleted BOTH my cashe and addons BEFORE i patched a week ago. Not being able to target/loot things was very rare at first but has been getting ALOT worse. even more so in zones that have the Cross realm going on.

Speaking of Cross Realm Zones. I think this is half the reason for the problems in Wintergrasp AND the loot/target bug. Maybe the server says i should NOT be able to see that entity because i caught it mid cross or something and therefore the entity is on a different realm.

BTW, This makes me feel like im playing a bad version of Chrono Cross =P Pun intended.

Join the Conversation

Return to Forum