WoW Launcher Not Working AGAIN!!

I also want to confirm that this fix also works for EU
Having major issues. Tried logging in today and found the launcher relaunching itself after every attempt. Uninstalled WoW completely and now it won't reinstall at all. Keeps giving me an error message say files failed to install before it even begins. Anyone help? Says I need to check internet connection and try again
i am running on a mac and i cannot find how to fix the launcher, it is stuck at 0% and doesnt move can somebody help me
I Have tried everything above! Ive deleted my folder..Ive restarted my pc......I unistalled, but now when I try and install the game using the launcher it does the same thing.......UPDATING BLIZZARD UPDATE AGENT.....
Yep, same here...stuck on UPDATING BLIZZARD UPDATE AGENT with partial green bar...
Still working dudes, just got mine fixed :) Thanks for the share guys.
i have windows 8 and it is alot different then 7 i can not launch wow i get the file error message can someone help me plz
same but i have vista.l...
I am having a similar issue, except my launcher will not appear at all. The first message appears but after the box disappears and the launcher would normally pop up nothing happens. When watching task manager Agent.exe *32 and Blizzard Launcher.exe *32 show up, but then close out after a few seconds. I am not sure if this is related or not, but my IE does not work either, I get a blank window that won't connect to any webpage. Chrome and other browsers work fine. I am considering upgrading to Windows 8 in the hopes that it will fix these issues. Currently I am running Windows 7.
I found this in the internet and works for me.

For whatever reason, Internet Explorer (which I never use) was set to "work offline". For whatever reason, with Internet Explorer set to work offline, the Diablo 3 installer was failing to do anything other than time out.

I disabled "work offline" by unchecking "Work Offline" in the file menu (available by pressing the ALT key in newer versions of Windows/Internet Explorer);

Once this option was disabled, everything worked first time.
Thank you so much for this, i was becoming overly annoyed with it and searching to fix it but your advise worked with no problems at all, thanks :)
None of this apparently seems to work. I have repeatedly deleted the folder only to be perpetually stuck with Updating Blizzard Update Agent instead of the perpetual Checking for Updates screen instead.

Anyone have any more suggestions?
I was having the same problems. Deleted the folder, etc. Nothing worked. Then I went back to searching for solutions on the web and about ten or more minutes later, the launcher started responding with "reconfiguring game files" (I haven't played in more than a year) and an updated launcher GUI. So, apparently it's working. All I can say is... wait? Good luck, folks.

Oh, Win 7/64.
I had the exact same problems everyone else is having...
I deleted that folder ... Updating blizzard agent...stuck after partial green load

Go go Control panel > System and Security > Windows Firewall >
Allow a program through windows firewall = blizzard agent,
OR just disable your firewall completely :)

This issue seems to happen more times and more often than I care for.

My launcher doesn't even pop up when I click either the short-cut on my desk top, the icon on my start menu, or straight from the folder itself.

After following the instructions to reveal hidden files to (hopefully) delete the or Agent folders, it still persists and I am unable to start the game.

But my biggest beef is: Why do I need to do this? I've had the game since the start, and I've had to do go through these steps more often in the past three months than I have in the past eight years.

I have no problems with firewalls or anything else. I've just deleted both Agent folder and, afterwards, the folder to no avail. Do I really need to uninstall and reinstall the game?
Just spoke to a great WoW rep (thanks Colleen!), and her first piece of advice worked like a charm:

Close launcher and anything else WoW related
Open Internet Explorer
Leave it open but don't do anything with it
Re-open launcher

Immediate fix. I had forgotten that I even had IE, but apparently it will prevent certain actions unless it's open.

Thank youuuuu!!!!
Sweet ty
01/23/2014 06:08 PMPosted by Amirro
Sweet ty

Nice necro bro....

Join the Conversation

Return to Forum