Internal Error when running Launcher

Technical Support
Every time I run the Launcher this morning I get an "Internal Error" message and it closes if I click "ok". Everything was running fine last night when I logged off. The power in building did flicker early this morning, but I don't see how that would have messed up the WoW Launcher... Anyone else having trouble logging on this morning?
yes having the same problem not sure
I also have that same problem. Any news one how to go on about it?
Having trouble too, glad to see I'm not alone. Just put in a ticket, so we'll see what they have to say.
Same problem. I've tried turning off all anti-virus programs, uninstalling via Windows Control Panel and re-downloading the game client. Still not working.
Having the same problem, not fun :-(
Having the same problems not even working for me at all, havent even had he chance to play:(
Same thing happening to me. Whats going on Blizz!!!
I'm having the same problem.
Same issue. Submitted a ticket but I have noticed internal error and fatal error messages since the patch.
sure glad its not just me guess I will submit a ticket now too
same here internal error , and launcher goes away after clicking ok, uninstalled game, now can't even get it to download for re-install...
To add some details, when launching I got a "Trojan horse Generic29.ASNJ" detection from file "wow.exe" in AVG. I've never had anti-virus issues with the launcher before so I healed it. The warning is gone now, along with the wow.exe file.

That being said, I am still able to run the client (64-bit for me) directly by starting it from the game folder and bypassing the launcher. It seems there's an issue directly related to the launcher and not the game itself.

Hope this helps a few people and gives a blue some details as well.
Also having the same problem on an iMac... and when i dont get that Internal error i cant log in. it will freeze for 45sec - 2mins before it says ive been d/c from the servers
I am having the same problem...I have been playing the game fine after the patch but this morning after grabbing some coffee and sitting down to have some fun for a bit but now I'm getting this internal error when I try to launch the game. AVG also found the Trojan and I deleted the virus from the vault but nothing happened game wise. Still cant play. If someone finds a fix, Please walk us through it step by step for those of us not so savvy folks. Thanks guys and gals. =)
I am still able to log in and play with no DC. This is what worked for me (YMMV depending on OS and 32- or 64-bit clients):

*Open your Hard drive directory
*Open "Program Files (x86)" folder
*Open "World of Warcraft" folder
*Run "WoW-64.exe" file

That launched the client for me with no other issues. Again, I am running the 64-bit client, so the file you're looking for may be labeled as something different, but similar. If it is in fact the "wow.exe" file that AVG (and I would assume other AV programs) is removing and needed for client launch, it may be a Blizz only fix.
Still haven't heard anything, would be nice to be able to get on today.
Having the same issue and still can't get on. Has to do with AVG I made the exception and it still isn't working...
I am having the same issue. I put in a ticket....

Join the Conversation

Return to Forum