Failed to launch critical file on Mac

Mac Technical Support
i downloaded the official game client off battle.net because i was having optimization issues with the disk. i deleted all the original wow files and started the download through a file called World of Warcraft setup.the download is done and each time i press play in the blizzard launcher it says failed to launch critical file. why is this happening?
bump
I also been having this problem
same
Failed to launch a critical file means that you're missing either World of Warcraft.app or World of Warcraft-64.app from your World of Warcraft directory. Can you double-check this and see if you're missing the file? Your directory should have these files/folder:

Cache
Data
Interface
Launcher.db
Logs
Movies
Screenshots
SetupOSX.mpq
Updates
WTF
WoW.mfil
WoW.pfil
WoW.tfil
World of Warcraft Launcher.app
World of Warcraft-64.app
World of Warcraft.app

If you moved any of the files in the folder to the desktop in order to create a shortcut, please try moving it back and create an Alias instead.
Except I can't even find the WoW Directory on my computer. All i can find is World of Warcraft Setup to launch the application to generate this error. I don't know how to fix please help.
I have never had a World of Warcraft-64.app in the directory. How do I get one? It was running fine last night without it. What changed? Do I need to completely reinstall?

EDIT: I just went to download the game client again, but all it downloaded was World of Warcraft Setup.app, which opened the launcher I already have. Should I delete all of that?

EDIT 2: I deleted my World of Warcraft folder, and Setup re-downloaded everything and it works now, has all the right files. I don't know if there was an easier way to do it, I still have 18 GB to download, but...it worked.
Same problem. Downloaded from the official site but looks like it does not download the required files.
It should download all the files. Did you every try to make a shortcut by moving something to the desktop, or move anything to the trash?

I've tested the installer quite a few times, and it always seems to install both a World of Warcraft.app and a World of Warcraft-64.app file every time.
It didn't download the files for me and I didn't shortcut anything. Since I've uninstalled the game again and reinstalled using the client a second time and this time all seems in order.
same here... did yo u find the solution
hi, i have the same problem. i have tried downloading the game client and get the same message. no other files download with it so i cannot reinstall it. help!
Same issue. No folders or files created....
Ok...this is how i solved my issue...

1. First of all, I did not uninstall WoW properly from my Mac (more on how to do so properly in a sec). Basically, I had just deleted the WoW folder from Applications and did NOT empty my trash....so the installer updated my WoW game folder in the Trash!!!! So I restored the WoW folder from the trash and it had all the correct MoP files.

Go figure.

2. In the launcher, go to the menu Options > Games Prefrences and check the 32-bit client.

Done. Working now.

If you want to completely uninstall WoW from your Mac you can follow these steps:

In order to remove World of Warcraft safely from your system, you will need to:

1. Go to your Mac HD/Applications folder and move your World of Warcraft to the Trash
2. Go to your Mac HD/Users/Shared folder and move the Blizzard folder to the Trash
3. Go to your Mac HD/Users/your account/Library/Preferences and delete any files associated with WOW:
(You might not have all of these files.)

- com.blizzard.downloader.plist
- com.blizzard.Downloader.prefs
- com.blizzard.errorreporter.plist
- com.blizzard.Installer.plist
- com.blizzard.launcher.plist
- Com.blizzard.World of Warcraft.prefs
- com.blizzard.World of Warcraft.survey.prefs

4. Empty Trash
5. Install WoW from https://us.battle.net/account/management/download/ or you can log into us.battle.net and go to Manage Games>Download Game Client>Full Install (Mac).

This will start the new patching agent. This has the ability to play after Phase 1 is complete in the download process while it still patches. It has also eliminated a lot of issues and errors that the old patching system had. Just be aware that if you do start playing in Phase 2, there is a high chance of graphic issues, low FPS & high latency. Now they will go away after it is patched all the way, but at least you can play while it is patching rather than waiting until it is 100% complete.
Thank you! That happened to me as well and i could not figure out what I was doing wrong. I only needed to dump my trash, really was the last on my list of things I would have thought were wrong. Thanks again.
I did as said above and am still getting this error..
Thank you so much, this was the most helpful of all the wonderful stuff i was reading thru
I'm having an issue with the Launcher, it downloads the patches to a certain part and tells me that a file is corrupted.. 'wow-17128-OSX-final-MPQ' That's the file, does anyone have a solution?
i donthave WoW.mfil
WoW.pfil
WoW.tfil
World of Warcraft Launcher.app
World of Warcraft-64.app
World of Warcraft.app
THANK YOU SO MUCH OMG U DONT KNOW HOW MUCH I LOVE U RIGHT NOW!

Join the Conversation

Return to Forum