Can't download patch 5.0.5

Technical Support
For Mac users. i have just discovered a solution... was kind of by accident but it worked for me....

Firstly, i deleted my Cache, Interface, Updates and WTF folder from my World of Warcraft Folder. then i moved my World Of Warcraft Launcher Icon back into my World of Warcraft Folder (Previously moved it to my desktop for easy access rather than having to continually go into my World of Warcraft Folder) and tadah! it worked.

don't know if anybody else puts there World Of Warcraft Launcher icon on their desktop but yeah those are the steps i took and it worked.
I cannot get beyond "initilizing" 0% for patch 5.0.5 and cannot play the game without it. It is not a problem with my computer or. after speaking with my server, a problem with my local connection..........it is a problem in BLizzard. Why pay if we cannot play?
good timeing for blizzard to start failing with gw2 comeing out.
im having all these problems all i get is a window saying checking for updates then error pop up were are the reps at hellp us
i lost my launcher :(
I am having the same problems! The patch came up and downloaded as usual, but when I enter my info, it says the patch was not downloaded completely. I double checked and the patch notes section is saying it wasn't fully downloaded, but I cannot find a way to get it re-downlaoded or anything. For some reason, my friends computer (also a Mac with the same updates, etc.) works just fine. It is like #*####%*#!?
I have the same problem, my launcher stopped in 0%. i lost and frustrated :S, 6 hours awaiting.
For Mac users. i have just discovered a solution... was kind of by accident but it worked for me....

Firstly, i deleted my Cache, Interface, Updates and WTF folder from my World of Warcraft Folder. then i moved my World Of Warcraft Launcher Icon back into my World of Warcraft Folder (Previously moved it to my desktop for easy access rather than having to continually go into my World of Warcraft Folder) and tadah! it worked.

don't know if anybody else puts there World Of Warcraft Launcher icon on their desktop but yeah those are the steps i took and it worked.


This worked for me too! Thank you.
I only have 1 User Account on my Windows machine so I'm an Administrator, but for whatever reason running the Launcher as an Administrator allowed the launcher to download the patch.

I'm already an admin so it doesn't make any sense, but I when it comes to Blizzard I don't try to use logic anymore lol
Just another WOW Junkie having the same probs.
i can log in but then it say's patch required
and when i open the launcher it says upto date
ahhhhh
okay i sorted out mine. Im using a mac and all i did was move the wow-64, and both the wow launcher + blizzard launcher into my wow folder in the applications. Ran the normal wow (not the 64) and the patch downloaded. Log in was fine, and can log into my realm. Im not sure about pc but im thinking it'll be the same solution. Hope this helps
If any of you are having trouble downloading that patch i have a solution and its the only 1 that worked for me since blizzard doesn't know how to even run their own games.

First off you need to put the wow.exe file to xp(service pack 3) and then you need to go to start>control panel>administrative tools>services>Secondary Logon needs to be enabled to automatic. Alot of antivirus programs turn this off and for some reason blizzard made this patch so it had to use the fuction.

Best of luck to all of you hope this works for you
fix for windows

1. Go into the control panel
2. Open "Administrative Tools"
3. Open "Services"
4. Locate a service named "Secondary Logon"
5. right click and go to properties
6. down where it says startup type select automatic

may work for you, it worked for me
For Mac users. i have just discovered a solution... was kind of by accident but it worked for me....

Firstly, i deleted my Cache, Interface, Updates and WTF folder from my World of Warcraft Folder. then i moved my World Of Warcraft Launcher Icon back into my World of Warcraft Folder (Previously moved it to my desktop for easy access rather than having to continually go into my World of Warcraft Folder) and tadah! it worked.

don't know if anybody else puts there World Of Warcraft Launcher icon on their desktop but yeah those are the steps i took and it worked.


This worked for me too! Thank you.
Pure genius launcher is up and running again just when I was about to start ripping out my hair. Thank you so much!
i try to login nd i say i havr to restat so i press restart and it says that i have to eaither call techical support or reinstall and i try to reinstall already please can someone help me

Join the Conversation

Return to Forum