Guild Cataclysm Dungeon Hero Meta Bug

Bug Report
My guild has finally gotten around to working on guild achievements.
Before Tuesday maintenance we ran all heroic dungeons as a guild group to get the achievement GUILD CATACLYSM DUNGEON HERO. However, the blackrock caverns part remained grey even after earning the achievement (it shows the players who earnt the achievement though)
I checked forums and noticed issues with other achievements and decided to try again after maintenance. Tonight, we ran blackrock caverns again as a guild group thinking maybe we just need to do it again, but it still is greyed out and wont award the guild cataclysm dungeon hero achievement.

I dont know why it wont award the achievement but its shows that the guild has earnt the blackrock caverns achievement.
My guild is having this issue with Scarlet Monastery too, and with Mana-Tombs as well (up to now, the others haven't been completed yet). The Heroic: Mana-Tombs Guild Run and the Heroic: Scarlet Monastery Guild Run aren't appearing as completed in their respective metas.
Our guild is having this problem too. We are having problems with Guild Glory of the Cata Raider for the Dark Phoenix mount. I think all of the Meta achs are broken. Ours says we completed it, but it is greyed out for BWD. I have opened 2 in-game tickets, now a a third and even posted on forums several times. I have gotten no responses and keep getting ignored.

The in-game ticket responses are "thanks for reporting it". Very irritating when we work toward something as a guild and is completed, but we aren't rewarded and then we are ignored. I put in the 1st ticket 9/1 and here it is 9/12 with no information on this while other issues are being addressed. This post will too be buried with no information on the subject.

I have seen many threads on this subject especially on Guild Glory of the Cata Raider for the Dark Phoenix mount by different guilds/people and they were ignored too and people keep posting it b/c it hasn't been addressed. Not even with a simple "we are aware and working on a fix" like some of the other threads are getting. =(
Here is what Blizzard wrote to my in-game ticket maybe this will help...


Thank you for reporting this issue to us. After an initial investigation, it appears that this is an issue we are aware of and are currently working to resolve as soon as possible. We do appreciate the information, as all reports we receive are added to the information we already have and help us to better find a resolution.

For further updates regarding this and other issues, please visit our Forums at
I'm glad to see our guild isn't the only one having this issue. I still can't get it to recognize Mana Tombs for Guild Outland Dungeon Hero. It's also hit and miss on whether it's counting as we work through the Northrend dungeons. Also did Halls of Stone and Lightning and the guild achievement popup never showed up. But later noticed those were showing as counted on another character. At least with the guild changes to xp, us small, low level guilds can finally make some real progress. And having those vanity achievements points matter to us smaller guilds.
Sheesh, I'm glad too!

It appears that in some cases, the Guild Cataclysm Dungeon Hero has been solved, in others not. I guess it's a matter of time before everything gets fixed.
Our guild having same issue as stated above posts. We just completed the ZG achievement left for our meta for the guild cata dungeon heroic tonight and BRC. GB and VP are all grayed out but still showing as completed even with date. Would like to see a blue about this soon please.
Our guild has ran into this problem was well. All the required achivements are completed but Grim Batol and Blackrock Caverns didn't register for the meta. Has anyone had this problem resolved yet?
The same thing you describe happened to my guild tonight on the Meta "Guild Glory of the Cataclysm Raider. We ran BoT and TotFW and got the achievements for both but the Meta failed to trigger after we completed TotFW. Two of the three required raids are now green and hovering over TotFW shows complete with a list of guild members who completed it but it is gray.
Hoping this get fixed, the response i got from a ticket i put in 4 days ago was:
"We’d like to start by saying that after reviewing your petition we are sorry to tell you that we are not able to assist with your request. When petitioning in about an achievement issue; please understand that all achievements must be completed in-game. Even if you believe that you completed the requirements for the achievement (like defeating a heroic boss) we are still unable to give you credit. You will need to complete the run again.

Lastly, if you are looking for information about completing an achievement, we cannot give you hints regarding requirements to complete an achievement."

Such an annoying response, its like they didn't even read what the issue was and is.
We have tried running it again to trigger the meta but it did not work.
I need this bug fixed too.. need the reward for MoP leveling.
This bug is now fixed for my guild. Woohoo.

Join the Conversation

Return to Forum