Launcher stuck at "Checking for updates..."

Technical Support
When I open the launcher for World of Warcraft, it stays at "Checking for updates..." for about 5 minutes with no progress, then gives me an error. I have tried everything the support pages have said to do and still can't get past it. I was able to play after the Mists of Pandaria update, but then this problem occurred. I have also tried calling costumer support, but can get through as the lines are completely full.
help my friend kehbeh its an ordehr

no seriously she cannot miss pirate day.
You'd be best to ask over in Tech support.
You enabled secondary login, right?
________________________________________________
Customer Support Forum MVP
HDL - http://hdl-the-guild.com/~nodrama/
E-mail - neppyman.no@spam.gmail.com
"There's no point in being grown up if you can't be childish sometimes." -- The Fourth Doctor (in "Robot")
Yes, I went to the settings and it was already enabled.
Then you'll want to work further with the Tech Support folks. I'd recommend calling them.
________________________________________________
Customer Support Forum MVP
HDL - http://hdl-the-guild.com/~nodrama/
E-mail - neppyman.no@spam.gmail.com
"In the name of Elune, I will punish you!"
I've tried to call for about a week now and their call lines are completely full. :(
did you do a re-install lately or are trying to work it? try ctrl + alt + dlte then go to the processes take out agent and the launcher then keep trying you should have it working within a few times and work from that.

if that doesn't work i am sorry but that is what i did to get mine going.
Nope did that earlier :( Thanks for the suggestion though
my friend has the same issue
I got the same issue, tried every thing. Oh well account canceled till its fixed.
I have the same issue and I really don't want to have to reinstall the whole thing, not good enough when they are making so much money from us.
same problem. haven't been able to get on for about 5 days now.
same issue, its annoying as hell
same problem here i cant open the launcher itself, i can open the wow.exe and play just fine but the launcher isnt propelly opening, stays on the white box before the launcher that says "checking for updates"
Blizzard WTF get on this
Having the same issue here guys. :/
So am i i have even tried uninstalling it and reinstalling about 2 times and it still hasnt worked....
Same here, it let me run the wow executable directly, but not from launcher. Stuck at checking for updates. It always launches 4 Agent.exe processes in task manager, then crashes.

Well, now when i click the executable (starting today) the launcher is trying to take over. Very frustrating...

I am on Windows 7 Ultimate, wonder if it's an OS issue (tried all the commonly listed things)
Scidoosh, if you have any type of security program, please try each step below:

1) Configure your security program.

2) Disable your security program.

3) Uninstall your security program, and reinstall it afterwards.
________________________________________________
Account and Technical Services
If the Forum isn't helping, contact a Support Rep directly: http://us.blizzard.com/en-us/company/about/contact.html

Join the Conversation

Return to Forum