Guild Banks not opening

Bug Report
Seem to be unable to open all guild banks in SW (untested in other capital cities) also the Guild Perk for banks isn't working either tested on a variety of toons
Having the same issue on Twisting Nether. Confirmed by most of our guild members.
Same issue on ysera
Also on Wyrmrest Accord. In addition, the bar for guild XP is empty and the news section is blank. The guild info log is also blank.

I know it was working yesterday.
Same on Blade's Edge for certain characters in both TB and SW however a total game restart sometimes fixed the issue at least temporarily.

Related Issues?

  • Pot-bellied stoves, cooking tables and other types of cooking fires not working as expected, particularly in Dalaran although fireplace fires do work
  • Anvils in Dalaran not working as expected.
I'm having the same issue on Drenden. Just started this evening. All of my characters cannot access guild bank. I logged out, deleted WTF, Cache and Interface and that solved it for about 1 minute. I was able to get into the guild bank, but then it stopped working again as soon as I closed it and opened it back up.

Also, the guild progress bar isn't showing any xp.
Relogging while standing next to the guild bank will fix it until you run away. Unsure if it's just duration or distance, but soon after it won't work.

Unrelated, but as long as we're on the guild topic... Cannot promote anyone.
Same problems on Madoran. Can't get into the guild bank on characters that have moved between zones, and all guild news/exp bar are blank. I can access the guild bank and see the xp bar on characters that I've just freshly logged on to, but if I play for any amount of time, guild bank access and guild information vanishes.
So far a simple relogging is fixing it for my guild. I think it has something to do with CRZs. I know if I go into a zone that is a CRZ, my GupPet addon stops working properly because the mount ID table gets shuffled around. The times that I've not been able to open my guild bank I've also had problems with GupPet. I've tried it on a few other characters just to make sure, and the same thing happens. If I go into another zone and my GupPet stops working properly, I won't be able to access my guild bank. I'll also see a lot of information missing from my guild panel. A /reload fixes my mount ID table so GupPet works properly, but won't fix the guild bank. I still have to log out and back in.
Having this issue on Fizzcrank. Reload allowed me to access guild bank. Flew off and haven't tried again yet so don't know if I fixed it long term or short yet.
same issue in Cairne 2
issues on Shandris as well..

Can't open guild banks

XP not counting towards our guild as of this evening.

Rick
Bump...

Same issue on Alexstraza. Only resolution is to log off the toon or exit WOW completely. Reloading the interface doesn't seem to work for me.
Moonguard as well.
i heard stormwind is down so gbank isnt working or something
try bugs of all kinds related to guilds
Same issue on Perenolde.

It wouldn't open so I relogged. It opened, but then I was working on the bank for about 5 minutes- still had it open- and it stopped accepting the items I was trying to put in.
Same in Stormreaver.I exit the game and log back on and it works and then a few minutes later it wont open again. Hope they see this and fix it.
Seeing the same issue on Galakrond, but I can at least see the guild xp bar.

Join the Conversation

Return to Forum