Combat text not displaying.

Bug Report
Since 5.0 i've noticed that my combat text will not display when in instances of any size. I've double checked to make sure that it is turned on. I've disabled all addons and the issue persists. Is this a known issue with the patch?
Do you mean the game's built-in damage text, the built-in Scrolling Combat Text, or combat logs? The more specific you are, the better
Oh sorry, yes I mean the games built in scrolling combat text. Happens on all my character where i'll be in an instance and attacking mobs but no numbers appear indicating the damage i'm doing. The numbers for what's happening to me are there but not what i'm doing to other things. This includes healing as i was dpsing as a disc priest in a low lvl instance and no damage or healing numbers would appear.
You're talking about two things at once. The game's combat text is divided into two parts.

First is Damage Text. In short, these are the numbers showing what you do. The white/yellow/orange numbers that appear over enemies when you damage them, the green numbers that appear over friendlies when you heal them, etc.

Second is Scrolling Combat Text. These are the numbers showing what happens to you. The red/purple numbers for damage you take, the green for healing you take, etc.

It sounds to me like you have simply disabled Damage Text. You can fix this in your settings - it's right above Scrolling Combat Text.
It's an intermittent issue, I just logged on the two characters that I've seen this happen on and the floating combat text on me and on target are enabled. I went and hit a couple critters and it showed up. But when I go into a instance that's when it stops showing up. Sometimes it will show up for a little while then it will stop displaying. Next instance I do i'll check to see if its still enabled and report back.
I'm getting the same thing.
Ok, was tanking on my prot pally and the floating combat text on target was there for a few mins then it stopped displaying, i checked my settings an they were still enabled. logged over to my priest and did an instance and the numbers were there for a few mins but they to stopped displaying after a while.
Same thing is happening with me. When I'm hitting a target dummy, the floating text is fine and working as intended. When I get inside a random, it stops. Options enabled and the entire bit. Happens on my alts as well.
Experiencing the same issue. It happens in instances/bg's as well as vashjir.. Have tried removing all addons, etc.. Tried tinkering with video settings as well but to no avail.

Any word on this?
Its happening to me, too, and only on some characters. I have disabled mods as well and do not have any combat text addons, anyway. It is very frustrating. Can we get a blue in here to address this??
Yeah, I am getting the same thing. It only happens when I'm in an instance... Maybe I should create a in game ticket?
Oh, finally, I found this thread. After many DAYS of intensive research and work (trial and error), I am 100% sure that we have a bug regarding Floating Combat Text. It happened to my Rogue in every instance. Open world damage shows correctly, but I can´t see anything whenever I get in a random dungeon or I manually enter any dungeon.

I quadra-checked about addons, interface options, etc... believe me, there´s a bug out there. And it only happens in some places and chars combination. For example, this DK does not have any problem doing instances. But with my Rogue, I can´t see the DMG in 100% of the instances I enter.

Please Blizzard, do not ignore this topic, it´s very frustrating to give up those beautiful yellow crits.

The GM gave up my ticket and he honestly said "I have no idea of what is happening, sorry".


Now it happened after 5 minutes of Battleground. Damage simply disappeared. Arathi Basin, in case it matters.
Ok this problem is very very annoying and it's not listed in the known issues in the sticky thread. Can some blue explain what's happening?
Here's a link for a French post about this issue:

I won't give up trying to fix this problem. Otherwise, goodbye WoW, unplayable for me.
Just had this randomly happen in Badlands tonight. Appears to be random and just a bug as normally I don't have any problems and the text is always enabled.

A simple /reload ui worked great and fixed it for me. Might do it for you too. Keep in mind there is a space between "reload" and "ui".
Just had this randomly happen in Badlands tonight. Appears to be random and just a bug as normally I don't have any problems and the text is always enabled.

A simple /reload ui worked great and fixed it for me. Might do it for you too. Keep in mind there is a space between "reload" and "ui".

One of the first things I've tried since I started my Odissey trying to get rid of this bug was the classic reload UI. Nothing positive happened here. I can not see the damage in instances during 100% of the time, with my rogue. There's no addon that can allocate the pop up numbers correctly above target's head, like the Blizzard's default combat text. SCT creates them over nameplates, but if there are several monsters with the same name (a common situation in WoW), the numbers pop up either in other targets nameplate with the same name or in the center of the screen, causing great confusion.
So, any news about this matter? I can barely play without that crits popping on my screen. Can you post your configs as well? (detailed). Maybe we have some hardware in common.

My setup:

Processor Intel quad core i7 2630QM
GeForce GTX 580M (latest drivers)
Mouse G9X Logitech
Monitor: 120Hz 3D ready monitor
RAM: 12Gb DDR 3 1333Mhz
I fixed the problem.
12/19/2012 07:23 AMPosted by Kard
I fixed the problem.

Mind telling us how?
I developed a step-by-step to solve this problem.

1. Delete WTF, Cache and Interface folders while the game is closed. Do not log in again until the end of the procedure.

2. Download the BETA drivers from nVidia. The latest version is 310.70.

3. Install the 310.70 drivers. Removing the previous version or using radical methods like registry wipe is not necessary.

4. Restart your machine.

5. Open Control Panel, then go to "uninstall programs" or whatever option is listed in your language, regarding the list of softwares installed in your machine.

6. Find "nVidia 3D Vision Driver" and uninstall it.

7. Open your World of Warcraft game normally. Go to options>interface>floating combat text, and make sure everything is checked according to your preferences.

Damage should be working now. Please give me feedback about this issue.

Join the Conversation

Return to Forum